summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-21 15:28:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-21 18:06:47 +0100
commitfb0d09126f7a6ebbb393af5d23dea7832d22c6bc (patch)
tree451de6e77159f64c833f127aa9aa930269244526
parentdev-python/httpcore: Bump to 1.0.4 (diff)
downloadgentoo-fb0d09126f7a6ebbb393af5d23dea7832d22c6bc.tar.gz
gentoo-fb0d09126f7a6ebbb393af5d23dea7832d22c6bc.tar.bz2
gentoo-fb0d09126f7a6ebbb393af5d23dea7832d22c6bc.zip
dev-python/urwid: Bump to 2.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urwid/Manifest1
-rw-r--r--dev-python/urwid/urwid-2.6.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index a0e31adc0dff..ef74dbd0a66e 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -8,3 +8,4 @@ DIST urwid-2.5.2.tar.gz 842160 BLAKE2B 72658842360f23104ab3b21fc247d01bbf8ea4b30
DIST urwid-2.5.3.tar.gz 848047 BLAKE2B 42815e22f2659ee25736767391afbf0189b5bec9d1100ce7631efd037989cfacac7ee921666e2400e1ef7ef114261a948cfac172ac993753ce151b370361d375 SHA512 80c32138347a618fc40e1a26fd174e708a9f8e4e9a8e09edc1d9261a9d73a644e356ce375654a55b5fb8838a820b8ba8b1cc47560c5b44c5c74677399845f578
DIST urwid-2.6.1.tar.gz 841705 BLAKE2B 8fb74c9f8eebe0ec8dd7b765cfec6525aa7d3f35fa43373e81c7861666f015ad135660d38b1cf413ec1248dce008fefb997e00547ecf014c507334dba33a7e02 SHA512 f2997b239402324ae4d1cefeb2970a0f39f417d477ed930b6f41a36ea1268f3d6be56bbf880bf755e4fa498c53ca659e801db7c525f5a5c279ac486754130e1d
DIST urwid-2.6.2.tar.gz 847531 BLAKE2B fdacadd0fa7f8da62adbac071944778faec5ab07d414b17e86592998ace798f4211d5db6290070338ea3f82cb9e0817603cf4e07a3ac77ef3b8f6b77733f77a6 SHA512 2293bd523f4697016d79778e8e9d391c3748626f38bebd043c2ef0e955ade07186725fa4d7a190dbf1cd2ab0e43bdd233c652a7b111710633f56002c49171f6f
+DIST urwid-2.6.3.tar.gz 847875 BLAKE2B 3d952862e0fd79bf94a8449d9d375334bed699b35f3ffc5ab683bb7cd40f1d25ba03b0ee3fdf10c91c4d3243e1b23bae2d689304bc765f96bd3e869da246adc9 SHA512 3b3ea569d8ef1f0ed2b6c372ea145f9a0b64915ba2641707e577d8a2a6a7abf7bd970ec5cefd4bae41d9973d0ea075e75d2c443547f3202d94dc95698869a4dc
diff --git a/dev-python/urwid/urwid-2.6.3.ebuild b/dev-python/urwid/urwid-2.6.3.ebuild
new file mode 100644
index 000000000000..0d52239b0d14
--- /dev/null
+++ b/dev-python/urwid/urwid-2.6.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Curses-based user interface library for Python"
+HOMEPAGE="
+ https://urwid.org/
+ https://pypi.org/project/urwid/
+ https://github.com/urwid/urwid/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf urwid || die
+ eunittest
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Trio event loop" "dev-python/trio"
+}