summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 09:49:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 09:49:01 +0100
commitfb0eeff79a83c27367ecbb452d4ba7fb46511d42 (patch)
tree38c8f4522aa74851a52d4aa14f3149b51f361cc6
parentsys-kernel/gentoo-sources: add riscv support (diff)
downloadgentoo-fb0eeff7.tar.gz
gentoo-fb0eeff7.tar.bz2
gentoo-fb0eeff7.zip
dev-python/pyotp: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyotp/Manifest1
-rw-r--r--dev-python/pyotp/pyotp-2.5.1.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pyotp/Manifest b/dev-python/pyotp/Manifest
index a06c9de78abe..a9b430a711ea 100644
--- a/dev-python/pyotp/Manifest
+++ b/dev-python/pyotp/Manifest
@@ -1 +1,2 @@
DIST pyotp-2.4.1.tar.gz 15232 BLAKE2B 0690364209bbbfc7bdaddc0204168a584696b98d974b203513ce8f6ffef9751ed1c9d19b7f875631805cf704ca494b2412eb731b0415fdedbae7f57ece630981 SHA512 4bd60ecef1ae22207732a539e5b46c3ca35fa6158da552e537aa522bfe2a2e0743f7426c437cd93cc9901ce5b834cbd9d9e4481eb95478871367f1d5373b67af
+DIST pyotp-2.5.1.tar.gz 15503 BLAKE2B 73cbfb37f0d795b5d7a538e7b973c0281f161226559df1a8db20d4df5121c0efbe8dc8b0bed806903a83dace3388efca6c1ec84a6b7ef21becbd020c04074ffc SHA512 628bcc4c18c469dff9007cbe2f4a9b55a2100e1845e3196fbf2f55fd37b6c95a0d4d5df7a31f8df3e84b8a1b48151cb8048574cf1cda6bc7c098c5c0fb6e5649
diff --git a/dev-python/pyotp/pyotp-2.5.1.ebuild b/dev-python/pyotp/pyotp-2.5.1.ebuild
new file mode 100644
index 000000000000..cf8967a7eb75
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.5.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords."
+HOMEPAGE="https://github.com/pyauth/pyotp https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest