summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-14 08:50:52 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-14 08:50:52 +0100
commitfb20d0c23eba92f4249026f6f9fccea45b6996cc (patch)
treee3dc8ce679cb3996d8c4977f7f6bcb7d49396f6d
parentapp-admin/ansible-lint: drop 6.12.1 (diff)
downloadgentoo-fb20d0c23eba92f4249026f6f9fccea45b6996cc.tar.gz
gentoo-fb20d0c23eba92f4249026f6f9fccea45b6996cc.tar.bz2
gentoo-fb20d0c23eba92f4249026f6f9fccea45b6996cc.zip
app-admin/ansible-lint: add 6.14.6
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.14.6.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 48d96a8acfa8..cd845f043733 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,2 +1,3 @@
DIST ansible-lint-6.14.2.tar.gz 473090 BLAKE2B 7ee73ab0b9539ae56cdf0220d79b271c45747fc1379f818e14f99b0d361e87cd7410548261e369a1d90cb3dceeb53bd46d614b041c837253ef643b653430bf51 SHA512 bb7350b56b9f81d398509b612cf1631020c21bed4f08ea8dda482460c18a1c0388269af513833778f29f1003a114366af885e7b7f31149731bad2067a904d30a
DIST ansible-lint-6.14.4.tar.gz 475223 BLAKE2B 01649f9890ca8c78097a810524fe6e6737cf77359d7537e799210ba25dd6aa0f7bb9f1e4a1ba80bb9dafcdedcde73d5c15bb71c47cc2ae18176e9d5cd91db093 SHA512 5274cab25bd648b87f1edaf55b480e3daf29d3ccc7c9d7c5f4013b96b7101c95ed264a2456789ad819be41712c8faad6206133ad26fa100353ef7d2d36c5fe43
+DIST ansible-lint-6.14.6.tar.gz 475624 BLAKE2B 99ac5214d7404c2cdaaf43678950b2031fd40396e45a27823feb708bc343b69181e624254b77bfe9f704a9037c60340f3a14d4a2651948b371ea91a28b1a1424 SHA512 dac9a089db2d2fe7b25f273b746571175d3ec974dbdf14d65cc10be83464f1ae88361d9e445d8687c011f817597fc4ca8d7501d192c6c529d9ec48997af8df7c
diff --git a/app-admin/ansible-lint/ansible-lint-6.14.6.ebuild b/app-admin/ansible-lint/ansible-lint-6.14.6.ebuild
new file mode 100644
index 000000000000..aff142066ce1
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-6.14.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-2.2.7[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.17.21[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}