summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-24 23:21:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 10:52:51 +0100
commitfb3f1f9b01cc7066e5e5012ad9906eff29a38900 (patch)
treeeebf175d9b675bbe5c8bfcd19709375ac7b4104e
parentsci-libs/hipBLAS: drop 5.0.2 (diff)
downloadgentoo-fb3f1f9b01cc7066e5e5012ad9906eff29a38900.tar.gz
gentoo-fb3f1f9b01cc7066e5e5012ad9906eff29a38900.tar.bz2
gentoo-fb3f1f9b01cc7066e5e5012ad9906eff29a38900.zip
sci-libs/hipCUB: drop 5.0.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sci-libs/hipCUB/Manifest1
-rw-r--r--sci-libs/hipCUB/hipCUB-5.0.2.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/sci-libs/hipCUB/Manifest b/sci-libs/hipCUB/Manifest
index 09237769ce17..bca0363ed4ca 100644
--- a/sci-libs/hipCUB/Manifest
+++ b/sci-libs/hipCUB/Manifest
@@ -1,2 +1 @@
-DIST hipCUB-5.0.2.tar.gz 243032 BLAKE2B 68256c0868bd23dbd78075ab286fc0738dc90f330a7e99186803e7920b3366f5608986dd9e3f4c5a045f9ec3f2461a66ab5b708d5d1d3fc748d042dd929a7993 SHA512 ae4d55fcf513eb5dd1316e335a0de30f6098eba70e877b41905bc59f3fb500ad9a46a28de77b74b914a15ffc38ad5c5f4dbdf36139505c26b94c43ffa5c90e01
DIST hipCUB-5.1.3.tar.gz 278021 BLAKE2B f30e567370fea80ef63a455c2c27b3f4ff241e7e405688fa4dc33d1e0ce3dffb016a1a1523b20613a7963bff061758eac0c0d110243a9a6cedbc100bb087d7d4 SHA512 dd3ca341b78cf6985ba723feeeb560c0503ab283b63067e9a5e68d12ad42f752a7f56fd60f0f0c26c2853538853e09a102cfc6006c18c31c3162fa7b536ffb9f
diff --git a/sci-libs/hipCUB/hipCUB-5.0.2.ebuild b/sci-libs/hipCUB/hipCUB-5.0.2.ebuild
deleted file mode 100644
index 176c254b3384..000000000000
--- a/sci-libs/hipCUB/hipCUB-5.0.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Wrapper of rocPRIM or CUB for GPU parallel primitives"
-HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipCUB"
-SRC_URI="https://github.com/ROCmSoftwarePlatform/hipCUB/archive/rocm-${PV}.tar.gz -> hipCUB-${PV}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="benchmark test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/hip
- sci-libs/rocPRIM:${SLOT}
- benchmark? ( dev-cpp/benchmark )
- test? ( dev-cpp/gtest )
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/hipCUB-rocm-${PV}"
-
-PATCHES="${FILESDIR}/${PN}-4.3.0-add-memory-header.patch"
-
-src_prepare() {
- sed -e "/PREFIX hipcub/d" \
- -e "/DESTINATION/s:hipcub/include/:include/:" \
- -e "/rocm_install_symlink_subdir(hipcub)/d" \
- -e "/<INSTALL_INTERFACE/s:hipcub/include/:include/hipcub/:" -i hipcub/CMakeLists.txt || die
-
- sed -e "s:\${ROCM_INSTALL_LIBDIR}:\${CMAKE_INSTALL_LIBDIR}:" -i cmake/ROCMExportTargetsHeaderOnly.cmake || die
-
- # disable downloading googletest and googlebenchmark
- sed -r -e '/Downloading/{:a;N;/\n *\)$/!ba; d}' -i cmake/Dependencies.cmake || die
-
- # remove GIT dependency
- sed -r -e '/find_package\(Git/{:a;N;/\nendif/!ba; d}' -i cmake/Dependencies.cmake || die
-
- if use benchmark; then
- sed -e "/get_filename_component/s,\${BENCHMARK_SOURCE},${PN}_\${BENCHMARK_SOURCE}," \
- -e "/add_executable/a\ install(TARGETS \${BENCHMARK_TARGET})" -i benchmark/CMakeLists.txt || die
- fi
-
- eapply_user
- cmake_src_prepare
-}
-
-src_configure() {
- # Grant access to the device
- addwrite /dev/kfd
- addpredict /dev/dri/
-
- # Compiler to use
- export CXX=hipcc
-
- local mycmakeargs=(
- -DBUILD_TEST=$(usex test ON OFF)
- -DBUILD_BENCHMARK=$(usex benchmark ON OFF)
- ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # Grant access to the device
- addwrite /dev/kfd
- addwrite /dev/dri/
- MAKEOPTS="-j1" cmake_src_test
-}