summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 14:03:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 19:08:16 +0100
commitfb448cd504da31d7ea98396e14c03199693ece40 (patch)
treee8d5020242f0f8ee3e02f2378445ac8b553c661f
parentsci-chemistry/votca-csgapps: Drop CMAKE_MAKEFILE_GENERATOR=ninja (diff)
downloadgentoo-fb448cd5.tar.gz
gentoo-fb448cd5.tar.bz2
gentoo-fb448cd5.zip
sci-chemistry/votca-xtp: Fix EAPI-7 bump, drop unused multilib
CMAKE_MAKEFILE_GENERATOR=ninja is default in EAPI-7/cmake.eclass Use https Use double brackets Sort RDEPEND Use BDEPEND Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-1.6.4.ebuild28
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-9999.ebuild28
2 files changed, 26 insertions, 30 deletions
diff --git a/sci-chemistry/votca-xtp/votca-xtp-1.6.4.ebuild b/sci-chemistry/votca-xtp/votca-xtp-1.6.4.ebuild
index fc37002f5a34..d9f436b0316c 100644
--- a/sci-chemistry/votca-xtp/votca-xtp-1.6.4.ebuild
+++ b/sci-chemistry/votca-xtp/votca-xtp-1.6.4.ebuild
@@ -3,35 +3,33 @@
EAPI=7
-CMAKE_MAKEFILE_GENERATOR="ninja"
+inherit bash-completion-r1 cmake
-inherit bash-completion-r1 cmake multilib
-
-IUSE=""
-if [ "${PV}" != "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+else
SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
S="${WORKDIR}/${P#votca-}"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN/-//}.git"
fi
DESCRIPTION="Votca excitation and charge properties module"
-HOMEPAGE="http://www.votca.org"
+HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
+IUSE=""
RDEPEND="
- ~sci-libs/votca-tools-${PV}
>=dev-cpp/eigen-3.3
- sci-libs/hdf5[cxx]
~sci-chemistry/votca-csg-${PV}
- sci-libs/libxc"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ sci-libs/hdf5[cxx]
+ sci-libs/libxc
+ ~sci-libs/votca-tools-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
DOCS=( README.md NOTICE CHANGELOG.md )
diff --git a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
index fc37002f5a34..d9f436b0316c 100644
--- a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
+++ b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
@@ -3,35 +3,33 @@
EAPI=7
-CMAKE_MAKEFILE_GENERATOR="ninja"
+inherit bash-completion-r1 cmake
-inherit bash-completion-r1 cmake multilib
-
-IUSE=""
-if [ "${PV}" != "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+else
SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
S="${WORKDIR}/${P#votca-}"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN/-//}.git"
fi
DESCRIPTION="Votca excitation and charge properties module"
-HOMEPAGE="http://www.votca.org"
+HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
+IUSE=""
RDEPEND="
- ~sci-libs/votca-tools-${PV}
>=dev-cpp/eigen-3.3
- sci-libs/hdf5[cxx]
~sci-chemistry/votca-csg-${PV}
- sci-libs/libxc"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ sci-libs/hdf5[cxx]
+ sci-libs/libxc
+ ~sci-libs/votca-tools-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
DOCS=( README.md NOTICE CHANGELOG.md )