summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Seifert <mseifert@error-reports.org>2016-03-22 18:38:04 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-03-30 12:03:27 +0000
commitfb4cb85a147a5325b874f769194b66cc4f116c4e (patch)
treef418fcb1878d6bddcb65a013f2fa507fdfb7881b
parentdev-util/buildbot: Added support for multiple service instances when using sy... (diff)
downloadgentoo-fb4cb85a147a5325b874f769194b66cc4f116c4e.tar.gz
gentoo-fb4cb85a147a5325b874f769194b66cc4f116c4e.tar.bz2
gentoo-fb4cb85a147a5325b874f769194b66cc4f116c4e.zip
dev-util/buildbot: Version migration elog message not displayed on fresh install.
Hides the elog notification about migrating to a new version of buildbot, if there was no previous version installed. Closes: https://github.com/gentoo/gentoo/pull/1027 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-util/buildbot/buildbot-0.8.12-r2.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-util/buildbot/buildbot-0.8.12-r2.ebuild b/dev-util/buildbot/buildbot-0.8.12-r2.ebuild
index c20323b55094..f7304091b1ed 100644
--- a/dev-util/buildbot/buildbot-0.8.12-r2.ebuild
+++ b/dev-util/buildbot/buildbot-0.8.12-r2.ebuild
@@ -91,10 +91,13 @@ src_install() {
pkg_postinst() {
readme.gentoo_print_elog
- elog
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the"
- elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the"
+ elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+ fi
}