summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-27 04:46:19 +0100
committerSam James <sam@gentoo.org>2021-07-27 04:46:19 +0100
commitfb5df2ae680d60a09a1ce09d8aedf71c249cedbf (patch)
tree469eadcac9ad3614d8d38fe1312b526b9eabcae0
parentnet-wireless/b43-fwcutter: update EAPI 5 -> 7 (diff)
downloadgentoo-fb5df2ae680d60a09a1ce09d8aedf71c249cedbf.tar.gz
gentoo-fb5df2ae680d60a09a1ce09d8aedf71c249cedbf.tar.bz2
gentoo-fb5df2ae680d60a09a1ce09d8aedf71c249cedbf.zip
sys-apps/fxload: update EAPI 5 -> 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/fxload/fxload-20081013-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-apps/fxload/fxload-20081013-r1.ebuild b/sys-apps/fxload/fxload-20081013-r1.ebuild
index 57edbfe85bd6..c934c82104a2 100644
--- a/sys-apps/fxload/fxload-20081013-r1.ebuild
+++ b/sys-apps/fxload/fxload-20081013-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -10,17 +10,17 @@ MY_P="${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}"
DESCRIPTION="USB firmware uploader"
HOMEPAGE="http://linux-hotplug.sourceforge.net/"
SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
src_prepare() {
+ default
+
sed -i \
- -e 's:$(CC) -o:$(CC) $(LDFLAGS) -o:' \
+ -e 's:$(CC) -o:$(CC) $(CPPFLAGS) $(LDFLAGS) -o:' \
Makefile || die
}