summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec dolsen <dolsen@gentoo.org>2018-07-26 10:02:46 -0700
committerBrian Dolbec dolsen <dolsen@gentoo.org>2018-07-26 10:17:11 -0700
commitfb680418b4464ce33c6e2afc48ce4b42db685bce (patch)
treed81fe9eb86c49f4b10d196e0bd45e36de823bf26
parentdev-util/buildbot-console-view: Version bump to 1.3.0 (diff)
downloadgentoo-fb680418.tar.gz
gentoo-fb680418.tar.bz2
gentoo-fb680418.zip
dev-util/buildbot-wsgi-dashboards: Version bump to 1.3.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-1.3.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 68dc69aed335..44fc45f44207 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-wsgi-dashboards-0.9.12.tar.gz 627274 BLAKE2B 26632ddd1577e9c419d13c07958c203440ef875bc4a79be6b894d0cf4dc457423528b7ea34c830511a5ef5d7f645fde2f71ac08578e1de32687c8b1ae2864491 SHA512 113c1616b08feb64fd3d94c1186e3d7dd7ea93e563a96ddb802e6ff8135e194014464ef09a23004518451626584bc531fc17419188ebbdd388e9363541b80c3d
DIST buildbot-wsgi-dashboards-1.1.2.tar.gz 626825 BLAKE2B 396fa858cafd6dc3958c37ea2e9e685357de2185ce0b73d946d3eb2e99472339e176de1b49d821337535904c521e8dbaa662217c568306e7b2d889d11fdeb5ed SHA512 1eee2a38b525145e50812dff421613291f6b0b6a80a531b54383d771393d2a12c1c7840e2dabf7949918ac3f31ce5f6bd9514c08dee8fe5900c99438e63d4ee2
+DIST buildbot-wsgi-dashboards-1.3.0.tar.gz 626828 BLAKE2B 9c44bca995a1849246c71cdf8ecca1a72ffdca9fb8e99db4e05dc529e0b188b85f45078c0f961c03eeb688fae08975dc438ba7c85bfcd3bebcc14a0d56a69f67 SHA512 97885bb26eb03c40b8424063333a9bbc80b5111ce82c79e0ca466f2f820622df43c6913b6b6f4f9ead2a47e09496ff9442df4a6a9a34041f6b9a127544413330
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-1.3.0.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-1.3.0.ebuild
new file mode 100644
index 000000000000..d40978a5739f
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-1.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}