summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-04 05:20:07 +0000
committerSam James <sam@gentoo.org>2024-03-04 05:20:40 +0000
commitfb7d223bb97be7db2af28d511e2342d45d59211e (patch)
tree1c41838cc6398493a5f8d80235d7dacc7b094781
parentgames-misc/typespeed: update EAPI 7 -> 8, fix build with LTO, fix group for l... (diff)
downloadgentoo-fb7d223b.tar.gz
gentoo-fb7d223b.tar.bz2
gentoo-fb7d223b.zip
sci-libs/lapack: restore filter-lto
In 58d080c1bad9b1c0d307f2cf2d0251d60025efb1, we dropped filter-lto, but the testsuite still fails to build with LTO, so put it back. Bug: https://bugs.gentoo.org/878891 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/lapack/lapack-3.12.0-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-libs/lapack/lapack-3.12.0-r1.ebuild b/sci-libs/lapack/lapack-3.12.0-r1.ebuild
index 9ccdd64e8562..b1b9e9824637 100644
--- a/sci-libs/lapack/lapack-3.12.0-r1.ebuild
+++ b/sci-libs/lapack/lapack-3.12.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Some additional tests are run if Python is found
PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake fortran-2 python-any-r1
+inherit cmake flag-o-matic fortran-2 python-any-r1
DESCRIPTION="BLAS, CBLAS, LAPACK, LAPACKE reference implementations"
HOMEPAGE="https://www.netlib.org/lapack/"
@@ -47,6 +47,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #878891
+ filter-lto
+
local mycmakeargs=(
-DCBLAS=ON
-DLAPACKE=$(usex lapacke)