summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-18 13:21:23 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-18 18:17:32 +0200
commitfb9c532fc04f8fdef947abd565e8f7bc99b465d3 (patch)
tree6261fb4145e123c8bbf5806a3286a380c7a945c0
parentacct-user/munge: add user (144) munge (diff)
downloadgentoo-fb9c532fc04f8fdef947abd565e8f7bc99b465d3.tar.gz
gentoo-fb9c532fc04f8fdef947abd565e8f7bc99b465d3.tar.bz2
gentoo-fb9c532fc04f8fdef947abd565e8f7bc99b465d3.zip
sys-auth/munge: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781491 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-auth/munge/munge-0.5.13-r2.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sys-auth/munge/munge-0.5.13-r2.ebuild b/sys-auth/munge/munge-0.5.13-r2.ebuild
new file mode 100644
index 000000000000..b10bf0e81697
--- /dev/null
+++ b/sys-auth/munge/munge-0.5.13-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools prefix
+
+DESCRIPTION="An authentication service for creating and validating credentials"
+HOMEPAGE="https://github.com/dun/munge"
+SRC_URI="https://github.com/dun/munge/releases/download/munge-${PV}/munge-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
+IUSE="debug gcrypt static-libs"
+
+DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ !gcrypt? ( dev-libs/openssl:0= )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/munge
+ acct-user/munge
+"
+
+src_prepare() {
+ default
+
+ hprefixify config/x_ac_path_openssl.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --with-crypto-lib=$(usex gcrypt libgcrypt openssl)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local d
+
+ default
+
+ # Bug 450830
+ if [ -d "${ED}"/var/run ]; then
+ rm -rf "${ED}"/var/run || die
+ fi
+
+ dodir /etc/munge
+ keepdir /var/{lib,log}/munge
+
+ for d in "init.d" "default" "sysconfig"; do
+ if [ -d "${ED}"/etc/${d} ]; then
+ rm -r "${ED}"/etc/${d} || die
+ fi
+ done
+
+ newconfd "$(prefixify_ro "${FILESDIR}"/${PN}d.confd)" ${PN}d
+ newinitd "$(prefixify_ro "${FILESDIR}"/${PN}d.initd)" ${PN}d
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}