summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-01-27 13:56:58 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-01-27 13:56:58 +0300
commitfba89edf9be44ed37396761afe1a590f13e0da85 (patch)
tree8f2a2895226e080be8c6ab55c1995d7b6d8e7ec0
parentdev-libs/opensc: arm stable wrt bug #704216 (diff)
downloadgentoo-fba89edf.tar.gz
gentoo-fba89edf.tar.bz2
gentoo-fba89edf.zip
dev-libs/opensc: Drop old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--dev-libs/opensc/Manifest1
-rw-r--r--dev-libs/opensc/files/opensc-0.19.0-p11test_common.h.patch108
-rw-r--r--dev-libs/opensc/opensc-0.19.0-r2.ebuild66
3 files changed, 0 insertions, 175 deletions
diff --git a/dev-libs/opensc/Manifest b/dev-libs/opensc/Manifest
index 016cba20da90..d75f0be41836 100644
--- a/dev-libs/opensc/Manifest
+++ b/dev-libs/opensc/Manifest
@@ -1,2 +1 @@
-DIST opensc-0.19.0.tar.gz 2080320 BLAKE2B c07df317f26562107680ed586e9a1ea83252c10a7dd227cffe51de709d9c888874963f6835a68f83f212d83f264b0231ea7428ed8d3ecce74cb9265d8191040a SHA512 90659133fb593cbf82ed6502e3858f34119bff051e3090489b7622659dcb1c26d389a4715892aa60a5606bc0ce115bd6c504521abfb965de9ad46441e4ed2b8e
DIST opensc-0.20.0.tar.gz 2140645 BLAKE2B 298a6d9c8a9682899cae201ba7edd464a2e3d947f6d97672727bedc47f6b529cb1495a8bc335f83cdb42b0c0077de0fd7ff9f3f8f506b543b1970cb6557b762e SHA512 71f71fa6062410e63c6c60f5b2d10d1d855cc6cc815ef0e42e42a1ddd25bbd52fc396c1e495ef54610f3243996dec84dacc8007b186deb670ed645b04ee6eda5
diff --git a/dev-libs/opensc/files/opensc-0.19.0-p11test_common.h.patch b/dev-libs/opensc/files/opensc-0.19.0-p11test_common.h.patch
deleted file mode 100644
index ca27c70245d7..000000000000
--- a/dev-libs/opensc/files/opensc-0.19.0-p11test_common.h.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-From d1e4f4879b8d0a7423afc1c9a3632da4763ee31c Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Sat, 15 Sep 2018 11:04:13 +0300
-Subject: [PATCH] missing include
-
----
- src/tests/p11test/p11test_common.h | 89 ++++++++++++++++++++++++++++++++++++++
- 1 file changed, 89 insertions(+)
- create mode 100644 src/tests/p11test/p11test_common.h
-
-diff --git a/src/tests/p11test/p11test_common.h b/src/tests/p11test/p11test_common.h
-new file mode 100644
-index 0000000..d3ca304
---- /dev/null
-+++ b/src/tests/p11test/p11test_common.h
-@@ -0,0 +1,89 @@
-+/*
-+ * p11test_common.h: Test suite shared declarations for PKCS#11 API
-+ *
-+ * Copyright (C) 2016 Martin Strhársky <strharsky.martin@gmail.com>
-+ * Copyright (C) 2016, 2017 Red Hat, Inc.
-+ *
-+ * Author: Jakub Jelen <jjelen@redhat.com>
-+ *
-+ * This library is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU Lesser General Public
-+ * License as published by the Free Software Foundation; either
-+ * version 2.1 of the License, or (at your option) any later version.
-+ *
-+ * This library is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * Lesser General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
-+ */
-+
-+#ifndef P11TEST_COMMON_H
-+#define P11TEST_COMMON_H
-+#include "config.h"
-+#include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <setjmp.h>
-+#include <cmocka.h>
-+#include "pkcs11/pkcs11.h"
-+#include "libopensc/sc-ossl-compat.h"
-+
-+#define MAX_MECHS 200
-+
-+#ifndef NDEBUG
-+ #define debug_print(fmt, ...) \
-+ { fprintf(stderr, fmt "\n", ##__VA_ARGS__); } while (0)
-+#else
-+ #define debug_print(fmt, ...)
-+#endif
-+
-+#define FLAGS_SIGN 0x01
-+#define FLAGS_SIGN_OPENSSL 0x02
-+#define FLAGS_SIGN_ANY ( FLAGS_SIGN | FLAGS_SIGN_OPENSSL )
-+#define FLAGS_DECRYPT 0x04
-+#define FLAGS_DECRYPT_OPENSSL 0x08
-+#define FLAGS_DECRYPT_ANY ( FLAGS_DECRYPT | FLAGS_DECRYPT_OPENSSL )
-+
-+typedef struct {
-+ char *outfile;
-+ FILE *fd;
-+ int in_test;
-+ int first;
-+ int in_data;
-+ int first_data;
-+} log_context_t;
-+
-+typedef struct {
-+ CK_MECHANISM_TYPE mech;
-+ CK_MECHANISM_TYPE hash;
-+ CK_RSA_PKCS_MGF_TYPE mgf;
-+ int salt;
-+ int usage_flags;
-+ int result_flags;
-+} test_mech_t;
-+
-+typedef struct {
-+ CK_FUNCTION_LIST_PTR function_pointer;
-+ CK_SLOT_ID slot_id;
-+ CK_SESSION_HANDLE session_handle;
-+ CK_UTF8CHAR* pin;
-+ size_t pin_length;
-+ char *library_path;
-+ unsigned int interactive;
-+ log_context_t log;
-+
-+ test_mech_t rsa_mechs[MAX_MECHS];
-+ size_t num_rsa_mechs;
-+ test_mech_t ec_mechs[MAX_MECHS];
-+ size_t num_ec_mechs;
-+ test_mech_t keygen_mechs[MAX_MECHS];
-+ size_t num_keygen_mechs;
-+} token_info_t;
-+
-+token_info_t token;
-+
-+#endif /* P11TEST_COMMON_H */
-+
---
-2.16.4
-
diff --git a/dev-libs/opensc/opensc-0.19.0-r2.ebuild b/dev-libs/opensc/opensc-0.19.0-r2.ebuild
deleted file mode 100644
index f02c94ebc573..000000000000
--- a/dev-libs/opensc/opensc-0.19.0-r2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1
-
-DESCRIPTION="Libraries and applications to access smartcards"
-HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
-SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~m68k ppc ppc64 ~s390 ~sh ~sparc x86"
-IUSE="ctapi doc libressl openct notify +pcsc-lite readline secure-messaging ssl test zlib"
-RESTRICT="!test? ( test )"
-
-RDEPEND="zlib? ( sys-libs/zlib )
- readline? ( sys-libs/readline:0= )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( >=dev-libs/libressl-2.7.0:0= )
- )
- openct? ( >=dev-libs/openct-0.5.0 )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
- notify? ( dev-libs/glib:2= )"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- test? ( dev-util/cmocka )"
-BDEPEND="virtual/pkgconfig"
-
-REQUIRED_USE="
- pcsc-lite? ( !openct !ctapi )
- openct? ( !pcsc-lite !ctapi )
- ctapi? ( !pcsc-lite !openct )
- || ( pcsc-lite openct ctapi )"
-
-PATCHES=(
- "${FILESDIR}/${P}-p11test_common.h.patch"
-)
-
-src_configure() {
- econf \
- --with-completiondir="$(get_bashcompdir)" \
- --disable-openpace \
- --disable-static \
- --disable-strict \
- --enable-man \
- $(use_enable ctapi) \
- $(use_enable doc) \
- $(use_enable notify ) \
- $(use_enable openct) \
- $(use_enable openct) \
- $(use_enable pcsc-lite pcsc) \
- $(use_enable readline) \
- $(use_enable secure-messaging sm) \
- $(use_enable ssl openssl) \
- $(use_enable test tests) \
- $(use_enable zlib)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}