summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-01 08:02:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-01 08:45:52 +0100
commitfbb8a89a4ff50fcfcf30d85f41c8e647e1cd6e5a (patch)
tree2e251fca1038321dde7a745d3e34f342571295f3
parentdev-python/imageio: Bump to 2.13.1 (diff)
downloadgentoo-fbb8a89a.tar.gz
gentoo-fbb8a89a.tar.bz2
gentoo-fbb8a89a.zip
dev-python/botocore: Bump to 1.23.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.17.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f990f8e9eb49..0073983a0b13 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,4 +1,5 @@
DIST botocore-1.22.12.tar.gz 8343683 BLAKE2B df7b2c86f226df14dc8181e8506acc7dd660797311049e2342ec721e853af1158c845749a8143ec6677601420ce6140173da8df5d9e4550cdf9becfc944ebd3c SHA512 0ab78902711960f8373a91af379b4981ab29646cc9f94e49836deaa432695c503879ed0bbbf54e3641e50933b5ed658e48052ca2b8b8391f705284d9abd24c1f
DIST botocore-1.23.14.tar.gz 8486875 BLAKE2B 93a3fd40b26d026dcee10172e560b4d59cdea803964e0f7ec85afbdd371d700ddc1594aad895730fc82d6684db4aa041b9c0e4e1b0b17ad701e5b87d082ca1ee SHA512 900afcb4d7378e1bd1f7a9dee1f6809151ad161f3442a7e197b2986db41af998d550d21ea225f66d1ff6374853da7bf13166186978edda08139a2c3093ff4b6c
DIST botocore-1.23.15.tar.gz 8499971 BLAKE2B d08fdcb398cd6bcb63a8922ebfb0f1c32c62190fb04e79e38db13ff51fbf45a0e1191037266ec4e96bb67d1c48e2510976a79591b06a7bb6d0cd57c89f8c81ce SHA512 df57fc9698d5bd5babbd0e94b4150fa287ecb3b32453532fe7cc87bb7dab87d181a7bedb85a57ca250987539f92b832e3a368d9faa39ae5ac641688d3907f818
+DIST botocore-1.23.17.tar.gz 8604819 BLAKE2B f6be48e3d0a2397be4934d9adaddbc4f2d70b2b002585e3057aead69ba934f4e53fcbffe7ea3f5919aa85d1cefe8c1abf6d1e150af6a18bd96561901d1ba7f87 SHA512 fecbb2f2ac451ffc97d7d8ad8224c3d1eff81fa225839199f403be9428cea203c077beb7c05e412784d8b6bedace3c1f24ca45730cc7877961931ac14912d1e1
DIST botocore-1.23.5.tar.gz 8374467 BLAKE2B 467092e7d8aa5ccb756132669049865445a47205913964c1c944b20caaf100b1efdd1bf3af9c5416ff079b487e6d4d08ffe6208e2b352d09655cc5be21c88739 SHA512 6afca19b724f9019f21e5993ce970d605b95d31c1a4e969ec1b4080510a5a120b3fa0cfd5ade973a9203bd6b7983a3dbca2f7a03108a9167392efd60d5e2fe9b
diff --git a/dev-python/botocore/botocore-1.23.17.ebuild b/dev-python/botocore/botocore-1.23.17.ebuild
new file mode 100644
index 000000000000..80a198d56414
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.17.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest tests/{functional,unit}
+}