summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-02-28 10:28:53 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-02-28 10:29:58 -0800
commitfbc8941f5ab0baa0ca54e2fc2b70b1f31cbf8f2a (patch)
tree8a8b5f2dd3ab56a05e4dd547d53bd843a9184e9a
parentdev-python/pycryptodome: Stabilize 3.17.0 arm, #898482 (diff)
downloadgentoo-fbc8941f.tar.gz
gentoo-fbc8941f.tar.bz2
gentoo-fbc8941f.zip
sys-block/ndctl: add 76.1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--sys-block/ndctl/Manifest1
-rw-r--r--sys-block/ndctl/ndctl-76.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-block/ndctl/Manifest b/sys-block/ndctl/Manifest
index f4f1e0773555..f6b9352e6773 100644
--- a/sys-block/ndctl/Manifest
+++ b/sys-block/ndctl/Manifest
@@ -1,3 +1,4 @@
DIST ndctl-71.1.tar.gz 330512 BLAKE2B 582f29fb649f33a48b5412bfefc15de2b1f765b27251d1b8a472d8c7705d671acbd6bf646f737baf8556d8fda39db68242f44e11225d7305e95f5d2ec5931f31 SHA512 92fb06ca64455775ce0b89ba0846f70235e02fe3502e2a8a55a858f76f87cb90ae98f5bf01620e5884f667ea78ee2bee2cd9e7a85ffa8f8d9c456e9282ca9ebc
DIST ndctl-72.1.tar.gz 365324 BLAKE2B 2e061bd1357c0b422f728e8624106d93e9eed2f5c7795428b0c61d041ab45569aa8bb6eb52544360ad538be85f3b7f84f8c9ab1037a8ca5498c2e1a13fa22186 SHA512 7304e23121c99457fa6e22a399fb636f6a66d6d07b090463ec41e424687b06e7e8a1a18623ab9dd5783aaccfa09ff964e3477b63aaa4614ac60f6e6050452f12
DIST ndctl-75.tar.gz 415393 BLAKE2B f9081b09c2f4ad8a6bc9c53e792b8a49992c7089af09e39917efe0fceea800d81665a31bf14c8e2f6f83c57d1dccebb4513b9bb556a3e81c19c75fbc67e1d7e3 SHA512 0af960e43a363711fbdb5152bb670022bd9b2f6a269c153dd88dca4ad2dcc215679c354ebcc758e9376867462f82c21aebe62bc62ca27333dedf3a818f34b272
+DIST ndctl-76.1.tar.gz 419651 BLAKE2B 52fdbb382a32005873e3be46d3c9b21c80e9ad53b5852c32d73d0ee966c61890d598d2b8d03fd0aa090970e5746daf52e91e70b9a79b328f1a2137a37bfb61a1 SHA512 76d32599df029969734276f8972f3f4bf701e471117c8a48d1f96b62c87a59ac54d59104ee62d1cbbb518a06a779677ca856df32ce6218d758a8c73daa3e5b06
diff --git a/sys-block/ndctl/ndctl-76.1.ebuild b/sys-block/ndctl/ndctl-76.1.ebuild
new file mode 100644
index 000000000000..e080d73a7e20
--- /dev/null
+++ b/sys-block/ndctl/ndctl-76.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev meson bash-completion-r1
+
+DESCRIPTION="Helper tools and libraries for managing non-volatile memory on Linux"
+HOMEPAGE="https://github.com/pmem/ndctl"
+SRC_URI="https://github.com/pmem/ndctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC0-1.0"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc libtracefs systemd test"
+
+DEPEND="
+ dev-libs/iniparser:0=
+ dev-libs/json-c:=
+ sys-apps/keyutils:=
+ sys-apps/kmod:=
+ sys-apps/util-linux:=
+ virtual/libudev:=
+ libtracefs? ( dev-libs/libtracefs:= )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+# tests require root access
+RESTRICT+=" test"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+)
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_feature systemd)
+ $(meson_feature libtracefs)
+ $(meson_feature doc docs)
+ -Dasciidoctor=disabled
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ -Drootprefix=/usr
+ -Drootlibdir="/usr/$(get_libdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # upstream doesn't install udev rules unless using systemd
+ use systemd || udev_dorules daxctl/90-daxctl-device.rules
+
+ bashcomp_alias ndctl daxctl
+ bashcomp_alias ndctl cxl
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}