summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-30 13:37:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-10-30 13:38:13 +0100
commitfbcb6e00d15a73628d36f14c30c03cd59e93f9a2 (patch)
tree38972447218c1f6189d5b9bf02280bb987068d20
parentdev-python/recaptcha-client: remove last-rited package (diff)
downloadgentoo-fbcb6e00.tar.gz
gentoo-fbcb6e00.tar.bz2
gentoo-fbcb6e00.zip
sys-devel/bison: Bump to version 3.2
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sys-devel/bison/Manifest2
-rw-r--r--sys-devel/bison/bison-3.2.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index fdc161c9deed..74f765f9d907 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -4,3 +4,5 @@ DIST bison-3.0.5-patches-1.1.tar.xz 5188 BLAKE2B 437a202cfc2431a5fe9a31ea6bcce59
DIST bison-3.0.5.tar.xz 1954868 BLAKE2B b6a8b426304f414c1b7601e75dcae8a63847b71361fba2538ad5cc52f3527fe464b066add670a236d5e1d2aff65bbe7a99c282ee3c72a0bfaa498d40e3a50398 SHA512 00b448db8abe91b07e32ff5273c6617bc1350d806f92073a9472f4c2f0de5d22c152795674171b74f2eb9eff8d36f8173b82dacb215601bb071ae39404d4a8a2
DIST bison-3.1-patches-1.0.tar.xz 7268 BLAKE2B 9195c00be1706664762598926913cd8fc18a32a6ae6ae4ec58748d5e8fc4877f63258db51cbe3bf84f3345ea0fc7c27d2e1190632c529615d9e6922baef74915 SHA512 5569b7901b40ea01eb7bccdc1b090207bc1ea6c50d144b561b2725ae79f3bcd51e7ea4e8ea37b60ea50ff4882e82110a07986cba1d2397a0333e7e01ae466e79
DIST bison-3.1.tar.xz 1990536 BLAKE2B 6223642f2934927ca118410e2655f7c677bb1d3d981875ca2224f5aa344a43efbbbea34e79dff94ea489853e505b1d7f5920f4d159d1464ce61d8956ca0401ad SHA512 2a8e217ffb55ed5b1fcc989377ac348a066e62b8a4b0b0da40c3c7202f3ea487b2aab6a704a10b48d2d17673be0e22f6ff1be91fc05c4e0a57969b42a59d0152
+DIST bison-3.2-patches-01.tar.xz 7696 BLAKE2B 5a83c118204173a8c264a1e9ca929612c8c1cceea40c2f45057ed053c34087b0dbef0bd25d299e9c928c192a68d55b83687c54cf3cab7c28ed557b2eac12ad5a SHA512 5fe6d40ac1f388764989653a8f1289d1368b75952ffae271e015853dc5c70a85430573a3ab261cca8d498d87f590b1257c6e72a7adb72a51a5f3e3bc56d87ec2
+DIST bison-3.2.tar.xz 2088320 BLAKE2B dacdf492ca49e51d30cd134db763bd174612d3e49531325f524fc1af602ba11068abdc2fac18a3698cf0f24508b6297a437f9d7ab81639869840ca1348f0b012 SHA512 2ca555df9b25f0764698cb152269dc1c24816ffeb6f912c12d1c8d1cf067f73e63c953ab2040b4dd894e6cc46a0d5b2f7cdae0ad8303e40fcd687b42d7d91410
diff --git a/sys-devel/bison/bison-3.2.ebuild b/sys-devel/bison/bison-3.2.ebuild
new file mode 100644
index 000000000000..4de6feafecc7
--- /dev/null
+++ b/sys-devel/bison/bison-3.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+PATCHES="${P}-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
+
+DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.1-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${PN}-3.2-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED%/}"/usr/bin/yacc{,.bison} || die
+ mv "${ED%/}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED%/}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED%/}"/usr/share/${PN}/README "${ED%/}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}