summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-31 09:29:42 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-31 09:45:33 +0100
commitfbe684c272565cd2c8ca72e0dd04eab09ac3af32 (patch)
treea17f9575c6702fbdfae24d57f8645094d3eccdab
parentdev-ruby/tty-platform: enable ruby33 (diff)
downloadgentoo-fbe684c272565cd2c8ca72e0dd04eab09ac3af32.tar.gz
gentoo-fbe684c272565cd2c8ca72e0dd04eab09ac3af32.tar.bz2
gentoo-fbe684c272565cd2c8ca72e0dd04eab09ac3af32.zip
dev-ruby/tty-cursor: update EAPI 7 -> 8, add ruby33
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/tty-cursor/tty-cursor-0.7.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/tty-cursor/tty-cursor-0.7.1-r1.ebuild b/dev-ruby/tty-cursor/tty-cursor-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..bf71d2b5e4ef
--- /dev/null
+++ b/dev-ruby/tty-cursor/tty-cursor-0.7.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="tty-cursor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Move the terminal cursor around and manipulate text using intuitive method calls"
+HOMEPAGE="https://github.com/piotrmurach/tty-cursor"
+SRC_URI="https://github.com/piotrmurach/tty-cursor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}