summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-06 10:38:30 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-06 10:57:35 +0100
commitfc0377a0bee8c25243f549bf015cd5d33668e5f6 (patch)
treed20240ac0de58e6cfc583422394e2850a3f82e8a
parentapp-eselect/eselect-python: Do not update meaningless py2 preference (diff)
downloadgentoo-fc0377a0bee8c25243f549bf015cd5d33668e5f6.tar.gz
gentoo-fc0377a0bee8c25243f549bf015cd5d33668e5f6.tar.bz2
gentoo-fc0377a0bee8c25243f549bf015cd5d33668e5f6.zip
dev-lang/python-exec: Silence the migration output for initial install
-rw-r--r--dev-lang/python-exec/python-exec-2.9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/python-exec/python-exec-2.9999.ebuild b/dev-lang/python-exec/python-exec-2.9999.ebuild
index 81e31934113a..14940d0d0a01 100644
--- a/dev-lang/python-exec/python-exec-2.9999.ebuild
+++ b/dev-lang/python-exec/python-exec-2.9999.ebuild
@@ -116,10 +116,12 @@ pkg_preinst() {
fi
done
- einfo "Keeping the following Python preference: ${old_pythons[*]}"
+ if [[ ${old_pythons[@]} ]]; then
+ einfo "Keeping the following Python preference: ${old_pythons[*]}"
- local IFS=$'\n'
- echo "${old_pythons[*]}" \
- >> "${ED}"etc/python-exec/python-exec.conf || die
+ local IFS=$'\n'
+ echo "${old_pythons[*]}" \
+ >> "${ED}"etc/python-exec/python-exec.conf || die
+ fi
fi
}