summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-15 20:12:42 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-17 11:42:41 +0300
commitfc0c6451b0c7dff637061283d9c98127cfcf1429 (patch)
treec9f9c557046e77a5876bd9a0d90d8d775fc33e5c
parentdev-python/orjson: Stabilize 3.10.3 x86, #932055 (diff)
downloadgentoo-fc0c6451b0c7dff637061283d9c98127cfcf1429.tar.gz
gentoo-fc0c6451b0c7dff637061283d9c98127cfcf1429.tar.bz2
gentoo-fc0c6451b0c7dff637061283d9c98127cfcf1429.zip
games-puzzle/tong: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--games-puzzle/tong/tong-1.2-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-puzzle/tong/tong-1.2-r2.ebuild b/games-puzzle/tong/tong-1.2-r2.ebuild
new file mode 100644
index 000000000000..615c89826b27
--- /dev/null
+++ b/games-puzzle/tong/tong-1.2-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Tetris and Pong in the same place at the same time"
+HOMEPAGE="https://www.nongnu.org/tong/"
+SRC_URI="https://www.nongnu.org/tong/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-fps.patch"
+ "${FILESDIR}/${P}-datadir.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:\"media/:\"/usr/share/${PN}/media/:" \
+ media.cpp option.cpp option.h pong.cpp tetris.cpp text.cpp \
+ || die
+ cp media/icon.png "${T}/${PN}.png" || die
+}
+
+src_install() {
+ dobin tong
+ dodir "/usr/share/${PN}"
+ cp -r media/ "${ED}/usr/share/${PN}" || die
+ dodoc CHANGELOG README making-of.txt CREDITS
+
+ make_desktop_entry tong TONG
+ doicon "${T}/${PN}.png"
+}