summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-09-24 15:52:23 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-09-24 15:52:35 +0200
commitfc754e1f540f10dbfd1b9e66e1edbf1c1c74727b (patch)
tree073c291911fd99f8b7c46e1c39e933a809c2a8c4
parentapp-benchmarks/geekbench: drop old version (diff)
downloadgentoo-fc754e1f.tar.gz
gentoo-fc754e1f.tar.bz2
gentoo-fc754e1f.zip
media-video/peek: 1.4.0 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--media-video/peek/Manifest1
-rw-r--r--media-video/peek/files/peek-1.4.0-meson.patch61
-rw-r--r--media-video/peek/peek-1.4.0.ebuild43
3 files changed, 105 insertions, 0 deletions
diff --git a/media-video/peek/Manifest b/media-video/peek/Manifest
index 4fd593e03e35..497e7b575def 100644
--- a/media-video/peek/Manifest
+++ b/media-video/peek/Manifest
@@ -1 +1,2 @@
DIST peek-1.3.1.tar.gz 2654939 BLAKE2B f5d2b6c9ca1194891ff6a61c73bcfc63a6e0bbf8a282c4309bbedbd40e29e42ad78d9c37c8a3621ceb6cb2ad85bbf2364702f1db028f6282dd4f93e15d22b34c SHA512 cdf4190c555b0a40051862038c04dc7c164bf8bccf47202d0fcb74f527a8a7d5605bc2e112847e262e51a5a95c3d2b3497e4ec56834880564e8e4127869ad9df
+DIST peek-1.4.0.tar.gz 2647446 BLAKE2B 688acb01e127c31fd9d8c6713757bf01e6b4ed1211a32787f5729b6a26308599a61c4ab057a2a008d3cc388f9492a41e70c34c92e90ded0058bbb325e9f828c8 SHA512 ef1723f72d1c575493b2e9192cee6038807d37d875a797781169e5f4640635deda947362dcf2e1a9149fcfe88de532b8ea05c665b14b1befaa9aa8c982d9aa31
diff --git a/media-video/peek/files/peek-1.4.0-meson.patch b/media-video/peek/files/peek-1.4.0-meson.patch
new file mode 100644
index 000000000000..9e66b7180a4b
--- /dev/null
+++ b/media-video/peek/files/peek-1.4.0-meson.patch
@@ -0,0 +1,61 @@
+diff --git a/BUILD_NOTES.md b/BUILD_NOTES.md
+index c146cbc..2d8c8b2 100644
+--- a/BUILD_NOTES.md
++++ b/BUILD_NOTES.md
+@@ -34,7 +34,7 @@ From inside the Peek source folder run:
+ ### Debian package
+
+ #### Build requirements
+- - meson (>= 0.37.0)
++ - meson (>= 0.47.0)
+ - valac (>= 0.22)
+ - libgtk-3-dev (>= 3.20)
+ - libkeybinder-3.0-dev
+diff --git a/README.md b/README.md
+index 71574b1..6faeb85 100644
+--- a/README.md
++++ b/README.md
+@@ -79,7 +79,7 @@ Support for more Wayland desktops might be added in the future (see FAQs below).
+ ### Development
+
+ - Vala compiler >= 0.22
+-- Meson >= 0.37.0
++- Meson >= 0.47.0
+ - Gettext (>= 0.19 for localized .desktop entry)
+ - txt2man (optional for building man page)
+
+diff --git a/meson.build b/meson.build
+index b0d57d7..5db2a39 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,6 +1,6 @@
+ project('peek', ['c', 'vala'],
+ version: '1.4.0',
+- meson_version: '>= 0.37.0',
++ meson_version: '>= 0.47.0',
+ )
+
+ add_project_arguments([
+diff --git a/meson_options.txt b/meson_options.txt
+index f88ceaa..526ccc9 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,4 +1,5 @@
+ option('build-tests', type : 'boolean', value : true)
++option('enable-keybinder', type : 'feature', value : 'auto')
+ option('enable-filechoosernative', type : 'boolean', value : false)
+ option('enable-gnome-shell', type : 'boolean', value : true)
+ option('enable-open-file-manager', type : 'boolean', value : true)
+diff --git a/src/meson.build b/src/meson.build
+index cf2c45a..5282148 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -48,7 +48,7 @@ enable_open_file_manager = get_option('enable-open-file-manager')
+
+ # Dependencies
+ gtk = dependency('gtk+-3.0', version: '>= 3.20')
+-keybinder = dependency('keybinder-3.0', required: false)
++keybinder = dependency('keybinder-3.0', required: get_option('enable-keybinder'))
+
+ peek_deps = [
+ dependency('cairo'),
diff --git a/media-video/peek/peek-1.4.0.ebuild b/media-video/peek/peek-1.4.0.ebuild
new file mode 100644
index 000000000000..7cab4b5a3799
--- /dev/null
+++ b/media-video/peek/peek-1.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome2 meson vala
+
+DESCRIPTION="Simple animated Gif screen recorder"
+HOMEPAGE="https://github.com/phw/peek"
+SRC_URI="https://github.com/phw/peek/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="keybinder test"
+
+RDEPEND=">=dev-libs/glib-2.38:2
+ media-video/ffmpeg[X,encode,vpx,xcb]
+ virtual/imagemagick-tools
+ >=x11-libs/gtk+-3.20:3
+ keybinder? ( dev-libs/keybinder:3 )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/txt2man
+ >=sys-devel/gettext-0.19
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-meson.patch )
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature keybinder enable-keybinder)
+ $(meson_use test build-tests)
+ )
+
+ meson_src_configure
+}