summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-01 15:43:17 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-01 16:09:41 +0100
commitfc8cf77088ff9402df87713f487c58f2d9d2600e (patch)
treec78ae9377fa04effe8a058862a56999fc08dfbab
parentapp-arch/lz4: Tested on ~amd64-fbsd (diff)
downloadgentoo-fc8cf770.tar.gz
gentoo-fc8cf770.tar.bz2
gentoo-fc8cf770.zip
app-arch/lz4: Bump to 1.8.1.2
-rw-r--r--app-arch/lz4/Manifest1
-rw-r--r--app-arch/lz4/lz4-1.8.1.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/lz4/Manifest b/app-arch/lz4/Manifest
index cf5a2b31602a..86debf382127 100644
--- a/app-arch/lz4/Manifest
+++ b/app-arch/lz4/Manifest
@@ -1,3 +1,4 @@
DIST lz4-1.7.5.tar.gz 208019 BLAKE2B a3d79d622eb0be2447cc6b0459bd81ae22b44ebe536ebd34b1c394bf1ff560c9b53e3f9203d5c94d046101a48d9b1ea7db74c39875d0a67b3a5f71d9633aa3b7 SHA512 b4e5b17fe06805e676608e636a45f0b480b79a02c6b7ffce84dc4d607861cb2652b2852493ab9d9249e7caeae6f00b6834801fdc39f58d901cbc1c7347915295
DIST lz4-1.8.0.tar.gz 222840 BLAKE2B 0b33f920f59a5ec9576051baa9ba887b320d424f8f64e1a752124371797d3f8bf2dbf13ee2e7268ef363d70697b8358e7ad627489c6843c61bdba004df80c5ec SHA512 aea46d4a900a3ede7dd7b498ee938ecd98397d3277c5b3a85b4236a44777cba85cd68a2f32c993b872afda96c5dafe0cb3dd391101fe8181e17c9f48884c1535
+DIST lz4-1.8.1.2.tar.gz 228640 BLAKE2B e5e7176dcce5319e2dcb1f6d69c47749976fd7e8c53c2379bdd0ef4c6f60bf426b2b58d606407f69d0b91e6835c9740265299107d11554e7a13963cdc855e8e5 SHA512 f4ed450bc05477cc6c2b42e6fe1fbb1fb0907f1d05b68b1d69d975b555ddb385550f204258e6d91642e14ce373815141dc218cda03b711793935d5458bc45c7f
DIST lz4-r131.tar.gz 133784 BLAKE2B f072d1f97ac6f804140c3896dfa95c16eb3c2c2208cfeb35a07535bb345fa100e4169ea91b2aa05655fb61f6f2d64a7c25444778b99841d3e3d0f09b10f570d8 SHA512 60bd95d529691ffee2c43f0d8a62484c3cff74c0154094f073192606806ac8182dced61e0534ffa7e0ccf5f18e9a8cfd2738883a83814c0711a6d7f1d1b252e5
diff --git a/app-arch/lz4/lz4-1.8.1.2.ebuild b/app-arch/lz4/lz4-1.8.1.2.ebuild
new file mode 100644
index 000000000000..42e9ba2e839a
--- /dev/null
+++ b/app-arch/lz4/lz4-1.8.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lz4/lz4.git"
+ EGIT_BRANCH=dev
+else
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+# 1.7.5->1.8.0 has some minor changes; the only really incompatible
+# would be removing 'const' from LZ4F_freeDecompressionContext() arg
+# however, it is extremely unlikely that this 'const' would actually
+# be relied on
+SLOT="0/r131"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/contrib/cmake_unofficial
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}