summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-02-12 08:33:07 +0100
committerHans de Graaff <graaff@gentoo.org>2022-02-13 10:06:06 +0100
commitfc960e47e0a8ce1fa2d5a177d41bb1d2e0fe4b73 (patch)
treedf975bbebf0f5ffde7e174d0b82bc751c4154135
parentdev-java/picocli: bump to 4.6.3 (diff)
downloadgentoo-fc960e47e0a8ce1fa2d5a177d41bb1d2e0fe4b73.tar.gz
gentoo-fc960e47e0a8ce1fa2d5a177d41bb1d2e0fe4b73.tar.bz2
gentoo-fc960e47e0a8ce1fa2d5a177d41bb1d2e0fe4b73.zip
dev-ruby/activesupport: add 7.0.2.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-7.0.2.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index fa69c7d46972..ba85cbaf42be 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -6,3 +6,4 @@ DIST rails-6.1.4.1.tgz 11003728 BLAKE2B 8baa45968536ebe34f3bc4e4f25246bff68997a8
DIST rails-6.1.4.3.tgz 11007190 BLAKE2B 085d500407f03d8c46335d91e3ebc5cd092c801de25f7e4fd5ac4ae6f03e54c5347e720386763307e183e2f0f48aaf84142092f47b62ab395082e4068e46f883 SHA512 f47a2e155fc80c287360b1a17a0f870208c523a28b77737648b4f260dc4fec6e9ccc91861b84862828fda48c214d39dcff32430ed5a02c8b9ee59ba6efb6151c
DIST rails-6.1.4.4.tgz 11006695 BLAKE2B af5afbd1adafa259f3d58d31e8e616be5e83e73d3e7231fd62717c0a8c0012e7ecf5346f2465a61f72d96fdc71755e954069adfebc84dddddcb29cb8a215cee1 SHA512 4215be8f447e5b486a1c0d99208fbeb1f7222aa3bdff7127e31c95670a74aa315a044df0048a55fd078f42a07f17d4b7248efc09d6fac2a4b6efef8624a509ef
DIST rails-7.0.0.tgz 11055620 BLAKE2B 5e85d60d45582aa4ff59f417a92611999c27115a2b568bf9baad089e983d96b7721e38123f85715b872b98074139b4a7ef0a6f74024b439792d70a5f40a4cd98 SHA512 dbe84e88abb577797c4f18d8062a8b3a4ecb8c6d8deaf29b50ccee9304e5852161b1628cf5e3d22ef69595791b791ab03536757aed7832a68615874047df86fd
+DIST rails-7.0.2.2.tgz 11034626 BLAKE2B 388a27b5434f1ae062cb7c3a68881a885dd659dbd9e86c4d36e0cb29c493f127fb9cbdf0f9ce7dea5a715ddbcd7a3bff5e2de3adb2e278c8bf63c2473d1e4b6d SHA512 e7863f1e072d266b8df1abb8abf6b141bad74ef77fe5dbcd66e7603e2ebf386520e4fd8f337edb5f5a6bd5607fbaa146823cbe6980fd7864e3934a7c9d382e3d
diff --git a/dev-ruby/activesupport/activesupport-7.0.2.2.ebuild b/dev-ruby/activesupport/activesupport-7.0.2.2.ebuild
new file mode 100644
index 000000000000..e921c0b3b547
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-7.0.2.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/minitest-5.1:5
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ dev-ruby/connection_pool
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/rexml
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|propshaft\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\|view\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}