summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-17 22:33:32 -0400
committerMatt Turner <mattst88@gentoo.org>2023-03-17 22:33:32 -0400
commitfcadac21dc0a4c27cb5c6d4fcc9a2c60f1b9ec5a (patch)
treeb05b17b121bb35a829e5e30321958b064ae19ba1
parentnet-libs/gnome-online-accounts: Version bump to 3.48.0 (diff)
downloadgentoo-fcadac21.tar.gz
gentoo-fcadac21.tar.bz2
gentoo-fcadac21.zip
net-libs/libsoup: Version bump to 3.4.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/libsoup/Manifest1
-rw-r--r--net-libs/libsoup/libsoup-3.4.0.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/net-libs/libsoup/Manifest b/net-libs/libsoup/Manifest
index 32d1fba1ed65..d7e9935eb133 100644
--- a/net-libs/libsoup/Manifest
+++ b/net-libs/libsoup/Manifest
@@ -1,2 +1,3 @@
DIST libsoup-2.74.3.tar.xz 1504804 BLAKE2B 91f441197414314bb78cf15e7c13b54714e669145784812fb7a68cc41c8965ea29c53dc686d690e00f28f711be9f767038e5cc43b11aa0136f190dd2d41ec2a0 SHA512 72f8a055df984cb35105fe67f4ca67d3fb110d40a9cacb660fccd89f93b06bc32e25d94375dcc76608a245f7c5e081d968d7aaf5952eb16013d81c741247cb4c
DIST libsoup-3.2.2.tar.xz 1530460 BLAKE2B 8df66651a0bdcdb3337ced0031e4e8a32883241f6b7310a2b91396883368fa849d1e7dbab3766ec38ec05fdd81fafabd1f165cfe22a168e87db9a431ca86274d SHA512 1f2b49244f8bac4d112b39ac9c6a942acbc1ae1cff33262ed02e7682af3994cf6ba6741b365b3c80c45c6427d391599fa6f31df6caa4ffefe7d078ac373bad1b
+DIST libsoup-3.4.0.tar.xz 1530892 BLAKE2B 9c5ad6ba8a476c633d8e6a65e6c3e910e4b4848e80284a0e47f67fba61efb8743973a1498ad5735dcfb92a7cd7517603de8a503e98aeb3e51029cf587562d67c SHA512 d9bc5c160e453d5bc467694dac057e03d9e6c075a87bd6ff59be4ddedbfcb496168d9457e905edc3aff569270f0401560001f3d54fca1a7c3679ac631bd779d6
diff --git a/net-libs/libsoup/libsoup-3.4.0.ebuild b/net-libs/libsoup/libsoup-3.4.0.ebuild
new file mode 100644
index 000000000000..73364f0a5c02
--- /dev/null
+++ b/net-libs/libsoup/libsoup-3.4.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="3.0"
+
+IUSE="+brotli gssapi gtk-doc +introspection samba ssl sysprof test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.69.1:2[${MULTILIB_USEDEP}]
+ net-libs/nghttp2:=[${MULTILIB_USEDEP}]
+ >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+ brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ sys-libs/zlib
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+ >=net-libs/glib-networking-2.70_alpha[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+ dev-libs/glib
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? ( >=net-libs/gnutls-3.6.0[pkcs11] )
+"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+PATCHES=(
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ "${FILESDIR}"/disable-apache-tests.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+ # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
+ sed -e '/hsts/d' -i tests/meson.build || die
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ # But unnecessary while apache tests are disabled
+ #addpredict /usr/share/snmp/mibs/.index
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature gssapi)
+ -Dkrb5_config="${CHOST}-krb5-config"
+ $(meson_feature samba ntlm)
+ $(meson_feature brotli)
+ -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+ -Dtls_check=false # disables check, we still rdep on glib-networking
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature vala vapi)
+ $(meson_native_use_feature gtk-doc docs)
+ -Ddoc_tests=false
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ $(meson_feature sysprof)
+ $(meson_feature test pkcs11_tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/libsoup-3.0 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}