summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2018-06-28 16:40:28 -0500
committerJory A. Pratt <anarchy@gentoo.org>2018-06-28 16:41:51 -0500
commitfcb9929d3ef6dea97679b0468592155142d970c1 (patch)
treebaa2bedf6cb224629267d7eae9a207bedb66d0f2
parentmedia-libs/imlib2: new maintainer (diff)
downloadgentoo-fcb9929d3ef6dea97679b0468592155142d970c1.tar.gz
gentoo-fcb9929d3ef6dea97679b0468592155142d970c1.tar.bz2
gentoo-fcb9929d3ef6dea97679b0468592155142d970c1.zip
www-client/firefox: Fix bug #656182, remove ffmpeg4 patch already landed
on esr branch
-rw-r--r--www-client/firefox/files/bug_1461221.patch36
-rw-r--r--www-client/firefox/firefox-60.1.0.ebuild3
-rw-r--r--www-client/firefox/firefox-61.0.ebuild2
3 files changed, 41 insertions, 0 deletions
diff --git a/www-client/firefox/files/bug_1461221.patch b/www-client/firefox/files/bug_1461221.patch
new file mode 100644
index 000000000000..8ffa42c3eaf7
--- /dev/null
+++ b/www-client/firefox/files/bug_1461221.patch
@@ -0,0 +1,36 @@
+
+# HG changeset patch
+# User Gregory Szorc <gps@mozilla.com>
+# Date 1526410966 25200
+# Node ID e4ce7b97291627f2186dc23be0dadd3c56dfe938
+# Parent f288a2c9c4390898a17ad9f964218b52b87d8028
+Bug 1461221 - Account for psutil.disk_io_counters() returning None; r=mshal
+
+Apparently it can do this.
+
+MozReview-Commit-ID: 6gMTGtcRAw6
+
+diff --git a/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py b/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py
+--- a/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py
++++ b/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py
+@@ -60,16 +60,19 @@ except Exception:
+ psutil = None
+
+ have_psutil = False
+
+
+ def get_disk_io_counters():
+ try:
+ io_counters = psutil.disk_io_counters()
++
++ if io_counters is None:
++ return PsutilStub().disk_io_counters()
+ except RuntimeError:
+ io_counters = PsutilStub().disk_io_counters()
+
+ return io_counters
+
+
+ def _collect(pipe, poll_interval):
+ """Collects system metrics.
+
diff --git a/www-client/firefox/firefox-60.1.0.ebuild b/www-client/firefox/firefox-60.1.0.ebuild
index e6ad0fecb10f..92566c51b7db 100644
--- a/www-client/firefox/firefox-60.1.0.ebuild
+++ b/www-client/firefox/firefox-60.1.0.ebuild
@@ -122,8 +122,11 @@ src_unpack() {
}
src_prepare() {
+ rm "${WORKDIR}/firefox/2005_ffmpeg4.patch"
eapply "${WORKDIR}/firefox"
+ eapply "${FILESDIR}/bug_1461221.patch"
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
diff --git a/www-client/firefox/firefox-61.0.ebuild b/www-client/firefox/firefox-61.0.ebuild
index df0c369af988..e3945abf8ec5 100644
--- a/www-client/firefox/firefox-61.0.ebuild
+++ b/www-client/firefox/firefox-61.0.ebuild
@@ -124,6 +124,8 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}/firefox"
+ eapply "${FILESDIR}/bug_1461221.patch"
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \