summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-27 20:49:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-27 21:25:23 +0300
commitfcc462904f8919c83484a2c38707ebe189537cdd (patch)
tree205e34c32b55b0c4fab217b3d080cfa5d29fc2d1
parentwww-client/chromium-bin: drop 105.0.5195.125 (diff)
downloadgentoo-fcc46290.tar.gz
gentoo-fcc46290.tar.bz2
gentoo-fcc46290.zip
dev-python/google-api-python-client: add 2.63.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.63.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index fe2cc097252e..373047f50e93 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.58.0.gh.tar.gz 33498127 BLAKE2B c00ecad1e863e5abb92cfbbbf57778b63ceaf73ae4cfb00ddf4fd0ed31656a28e475b91a02c03a6231790c2f3ab3e3243d131a97ed0f51151946568f5b56e18c SHA512 00c1606fadb46a6f4f60939135e9fd2840b267cd962630e4cd2d123588e9bdc8c0ed397d9e038ae91a2f31b732eb7698476fc1cf2322771b5720c11a97321b00
DIST google-api-python-client-2.60.0.gh.tar.gz 33586321 BLAKE2B 01bb4dcf8a9b90a65c4e58ded91a7c03c525c15d29dc5b63011e1d1b8281ea68c04526af29d7853f4b7e16681c2482970f3b95faa190522ddf2f0ad3dd4e5e50 SHA512 7cae2e66ae7a41d25e551a5e9b14757d62c0212fe18640b4c1b8f51ff9e0150cfb9a2492de67530c7d24d6d09231d365520c3c06ffb342ba4a68a1a07b69b27d
DIST google-api-python-client-2.62.0.gh.tar.gz 34525876 BLAKE2B 0f2bcd7588a6635511d3851f0a0881761d9cf905a83b406aaa824ef1ac86a3f9af9df2f90193b30852028b804fd30d8aa6214a5be83e26401a626ce3156e884f SHA512 4348bce74db02f74bd386d0276de2e2ec0126e7c1b79bea962056612f868d2b2306c51663ca293672db750460bd3722a66fb22139d14f30adcd3e0d455a2118a
+DIST google-api-python-client-2.63.0.gh.tar.gz 34736367 BLAKE2B 4657dd86a62def7d2858cefd63d8c8b23b36a38f65aa3e76f4436eb4d3334321fbda9530684b2d001883ba0345ef7de6d8447a86208023a3e77dae59269ef255 SHA512 a8253904fc9db8687be7a04356e9e11202073ce05c77f770d51ed973e0c87db32c4b39750e1a48d813186530dfeae0f76452df7241686d6a64afbdff35626387
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.63.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.63.0.ebuild
new file mode 100644
index 000000000000..7e8aaa05d6d4
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.63.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}