summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Strahl <c.a.strahl@gmail.com>2019-04-23 10:23:41 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-10 11:23:11 -0700
commitfcc6572987066b22e39345e483790efda0093ed6 (patch)
treef1400c76d34f7d1df8812ef08b4d56b7ff6a803b
parentdev-python/pytest-relaxed: last rites (diff)
downloadgentoo-fcc65729.tar.gz
gentoo-fcc65729.tar.bz2
gentoo-fcc65729.zip
dev-util/clion: version bump to 2019.1.3
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Christian Strahl <c.a.strahl@gmail.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2019.1.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index 5d11cb16815b..0a6efd50de11 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1 +1,2 @@
+DIST clion-2019.1.3.tar.gz 431393782 BLAKE2B 5612f8109d7ad7dc98990a8f549383086263a980b482fba0c2357e86fc09b474e597b0ce8f911f287b7ba6837247f2be47372a79ce416bb16e10c0ffdbec2588 SHA512 9c0971db22f87447edfcc6c6089470bbda507bff5755ccf4efff3dfb4704ebcb4b1b0fa71580824af2ee0a1bf0036475220deb5948bdf2f12e4f151cd55a230e
DIST clion-2019.1.tar.gz 429061573 BLAKE2B 14c2227509fd4c24d09ca139ff9f58ab2be71ad249d8f8a09d615cdc1aa07e9d2e0be9618e795859f564b63705a34e61dc90f3de5a012ad8fdf9a2f8ba512c33 SHA512 5c919ad2ea87744e0b3488958e58a9f67d8a8dcfa6affd86f975842c9e562663464d73373c72ef8085cede8f16828342dc17e182e761c199936bffee2f398509
diff --git a/dev-util/clion/clion-2019.1.3.ebuild b/dev-util/clion/clion-2019.1.3.ebuild
new file mode 100644
index 000000000000..ac0d030149b2
--- /dev/null
+++ b/dev-util/clion/clion-2019.1.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils
+
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="https://www.jetbrains.com/clion"
+SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror splitdebug"
+IUSE="custom-jdk"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+ dev-util/cmake
+ sys-devel/gdb
+ !custom-jdk? ( virtual/jdk )"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+ default
+
+ local remove_me=(
+ bin/gdb/linux
+ bin/lldb/linux
+ bin/cmake
+ license/CMake*
+ lib/pty4j-native/linux/ppc64le
+ )
+
+ use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
+ use arm || remove_me+=( bin/fsnotifier-arm )
+ use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
+
+ use custom-jdk || remove_me+=( jre64 )
+
+ rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
+
+ if use amd64; then
+ fperms 755 "${dir}"/bin/fsnotifier64
+ fi
+ if use arm; then
+ fperms 755 "${dir}"/bin/fsnotifier-arm
+ fi
+ if use x86; then
+ fperms 755 "${dir}"/bin/fsnotifier
+ fi
+
+ if use custom-jdk; then
+ if [[ -d jre64 ]]; then
+ fperms 755 "${dir}"/jre64/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
+ fi
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.svg" "${PN}.svg"
+ make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ dodir /usr/lib/sysctl.d/
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
+}