summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-03-01 18:39:46 -0500
committerMike Pagano <mpagano@gentoo.org>2023-03-01 18:39:46 -0500
commitfcd62a4a9e115d8eb2caafe9e719632c31d90a43 (patch)
treedbb1dfaa7b52115bac7a8fcaa73d0a9a4722edc7
parentsys-libs/libblockdev: fix documentation building on non-bash systems (diff)
downloadgentoo-fcd62a4a.tar.gz
gentoo-fcd62a4a.tar.bz2
gentoo-fcd62a4a.zip
dev-util/android-studio: add 2022.1.1.21, thanks to Adam Giergun
https://github.com/gentoo-mirror/adasss Closes: https://bugs.gentoo.org/894048 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--dev-util/android-studio/Manifest1
-rw-r--r--dev-util/android-studio/android-studio-2022.1.1.21.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index e7d3040a9ecc..63b988181e17 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -1,2 +1,3 @@
DIST android-studio-2021.2.1.14-linux.tar.gz 1010969463 BLAKE2B 24899d0b81303c5f7ad061afd80eac734444b313f40257d20dc99b99f11a867bb92fe7b77428e5431889fc2beabcea58a5875608087a5de96105675c42b2a8ba SHA512 9d9184828a8ca0007e613e53215b0af1abd2c79a482670fe7bbb708f2bcb144b8881ef2d1c89ca8e2528aedc1f3b7d4a40c0c6d3e20a16de520aaf075f6990a7
DIST android-studio-2021.3.1.16-linux.tar.gz 976205257 BLAKE2B 8854a346b751338bfadac61820a78f7ea9aa87828f9049a22d69221fc3ac2c4a9e6e738b84b2eb81023ceeb7866c35b74d38b0d9c2fca534df6e0947b6699b05 SHA512 4c033e1b5dd68fc73fe203ff19e134cf72d3a8faa9a9ba041bf478e529376f962c31d598b85e43a625fa56ef24f2ab6e13378125a7b710449daaf6d727ab51f5
+DIST android-studio-2022.1.1.21-linux.tar.gz 1014162603 BLAKE2B a3cc78ba4ba869d9615a55a90827171164ab961730681fa48962feeabf6a355930bb32d1822c31fb024f56f3e5d8d6880471505c3b48b1fe507ef15d44e2b0fa SHA512 5e850c6c5bb05923b41e4fafb0a20afcbec884cea427d5bb26a82e767930ef2c4477592e9338b1ea0458a3590d017f057a615749d9b9e1e8b364f67582ef0263
diff --git a/dev-util/android-studio/android-studio-2022.1.1.21.ebuild b/dev-util/android-studio/android-studio-2022.1.1.21.ebuild
new file mode 100644
index 000000000000..5cd01065fae6
--- /dev/null
+++ b/dev-util/android-studio/android-studio-2022.1.1.21.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop wrapper
+
+RESTRICT="bindist mirror strip"
+
+QA_PREBUILT="
+ opt/${PN}/bin/*
+ opt/${PN}/jbr/bin/*
+ opt/${PN}/jbr/lib/*
+ opt/${PN}/jbr/lib/jli/*
+ opt/${PN}/jbr/lib/server/*
+ opt/${PN}/lib/pty4j-native/linux/*/*
+ opt/${PN}/plugins/android/resources/installer/*/*
+ opt/${PN}/plugins/android/resources/native/*
+ opt/${PN}/plugins/android/resources/perfetto/*/*
+ opt/${PN}/plugins/android/resources/screen-sharing-agent/*/*
+ opt/${PN}/plugins/android/resources/simpleperf/*/*
+ opt/${PN}/plugins/android/resources/trace_processor_daemon/*
+ opt/${PN}/plugins/android/resources/transport/*/*
+ opt/${PN}/plugins/android/resources/transport/native/agent/*/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/android/*/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/bin/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/lib/python3.9/lib-dynload/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/lib64/*
+ opt/${PN}/plugins/design-tools/resources/layoutlib/data/linux/lib64/*
+ opt/${PN}/plugins/c-clangd/bin/clang/linux/*
+ opt/${PN}/plugins/webp/lib/libwebp/linux/*
+"
+
+DESCRIPTION="Android development environment based on IntelliJ IDEA"
+HOMEPAGE="https://developer.android.com/studio"
+SRC_URI="https://redirector.gvt1.com/edgedl/android/studio/ide-zips/${PV}/${P}-linux.tar.gz"
+
+LICENSE="Apache-2.0 android BSD BSD-2 CDDL-1.1 CPL-0.5
+ EPL-1.0 GPL-2 GPL-2+ JDOM IJG LGPL-2.1 MIT
+ MPL-1.1 MPL-2.0 NPL-1.1 OFL ZLIB"
+SLOT="0"
+IUSE="selinux"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.8-r4
+ >=dev-libs/expat-2.5.0
+ >=dev-libs/libffi-3.4.4
+ >=media-libs/fontconfig-2.14.0-r1
+ >=media-libs/freetype-2.12.1-r1
+ >=media-libs/libpng-1.6.39
+ >=media-libs/mesa-22.2.5[X(+)]
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ sys-libs/ncurses-compat:5[tinfo]
+ >=sys-libs/zlib-1.2.13-r1
+ >=x11-libs/libX11-1.8.1
+ >=x11-libs/libXau-1.0.11
+ >=x11-libs/libXdamage-1.1.6
+ >=x11-libs/libXdmcp-1.1.4-r2
+ >=x11-libs/libXext-1.3.5
+ >=x11-libs/libXfixes-6.0.0
+ >=x11-libs/libXrender-0.9.11
+ >=x11-libs/libXxf86vm-1.1.5
+ >=x11-libs/libdrm-2.4.114
+ >=x11-libs/libxcb-1.15-r1
+ >=x11-libs/libxshmfence-1.3.2
+ virtual/libcrypt:=
+"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ insinto "${dir}"
+ doins -r *
+
+ fperms 755 "${dir}"/bin/{fsnotifier,format.sh,game-tools.sh,inspect.sh,ltedit.sh,profiler.sh,remote-dev-server.sh,restart.py,studio.sh}
+ fperms -R 755 "${dir}"/bin/{helpers,lldb}
+ fperms -R 755 "${dir}"/jbr/bin
+ fperms 755 "${dir}"/jbr/lib/{jexec,jspawnhelper}
+ fperms -R 755 "${dir}"/plugins/Kotlin/kotlinc/bin
+ fperms -R 755 "${dir}"/plugins/android/resources/installer
+ fperms -R 755 "${dir}"/plugins/android/resources/perfetto
+ fperms -R 755 "${dir}"/plugins/android/resources/simpleperf
+ fperms -R 755 "${dir}"/plugins/android/resources/trace_processor_daemon
+ fperms -R 755 "${dir}"/plugins/android/resources/transport/{arm64-v8a,armeabi-v7a,x86,x86_64}
+ fperms -R 755 "${dir}"/plugins/android-ndk/resources/lldb/{android,bin,lib,shared}
+ fperms 755 "${dir}"/plugins/c-clangd/bin/clang/linux/{clang-tidy,clangd}
+ fperms -R 755 "${dir}"/plugins/terminal/{,fish}
+ fperms 755 "${dir}"/plugins/textmate/lib/bundles/git/src/{askpass-empty.sh,askpass.sh}
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
+
+ # https://developer.android.com/studio/command-line/variables
+ newenvd - 99android-studio <<-EOF
+ # Configuration file android-studio
+ STUDIO_JDK="${dir}/jbr"
+ EOF
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-android-studio-inotify-watches.conf" || die
+}
+
+pkg_postrm() {
+ elog "Android Studio data files were not removed."
+ elog "If there will be no other programs using them anymore"
+ elog "(especially another flavor of Android Studio)"
+ elog "remove manually following folders:"
+ elog ""
+ elog " ~/.android/"
+ elog " ~/.config/Google/AndroidStudio*/"
+ elog " ~/.local/share/Google/AndroidStudio*/"
+ elog " ~/Android/"
+ elog ""
+ elog "Also, if there are no other programs using Gradle, remove:"
+ elog ""
+ elog " ~/.gradle/"
+}