summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-01-31 16:39:42 +0200
committerMart Raudsepp <leio@gentoo.org>2021-01-31 19:51:20 +0200
commitfcd65dea218dcfeda416b88fe14c689b0ed284c0 (patch)
tree945ef68ac771676d530a2be258b28862bfa13d53
parentgnome-base/librsvg: bump to 2.50.3 (diff)
downloadgentoo-fcd65dea.tar.gz
gentoo-fcd65dea.tar.bz2
gentoo-fcd65dea.zip
app-misc/gnote: bump to 3.38.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-3.38.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index aca2de98d419..1162beb824e6 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1 +1,2 @@
DIST gnote-3.36.2.tar.xz 3511244 BLAKE2B d7b8859ec47f8da2d37f285141d4c7fc0f591751a1ebea70339d6cdb727c74a6ca711515f8169130e1b46c1653c0c98da3bc4bce691b8d7a7f2794745e8db2a7 SHA512 6d2e32954836b4ac2800071385eedd6ad391936ee52626b7d51b077e4b4a3e071149804281e645b0fd88dc18e9f3c0f8d53e0994d33875ce5375d6b50b14d5e1
+DIST gnote-3.38.1.tar.xz 3530348 BLAKE2B d3312162ffdf505dea31f8e8848bd755d6fc54a5f95250ce6b90a28e04801fb86a8c4e239471442a4501068a841e38e4764da8f16528849fdec57a88bd271891 SHA512 ccfe35ff3dc8e90fa96307565875401540c9e03a18ffd5b2c25fdb053927c4bb2b6b5515456f5260c053948b1a63bf6959a73e1ab09feefce61ed2adc257734f
diff --git a/app-misc/gnote/gnote-3.38.1.ebuild b/app-misc/gnote/gnote-3.38.1.ebuild
new file mode 100644
index 000000000000..2ebb668cff8b
--- /dev/null
+++ b/app-misc/gnote/gnote-3.38.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gspell-1.6.0:=
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.22.20:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.22.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}