summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-03 18:42:20 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-03 19:14:39 -0800
commitfce43338666f8d654bfa891b3e63ba57bbc3e312 (patch)
tree79040c91df4f0c21079b714013a5fec5802605ba
parentRevert "arch/amd64/u.s.m: un-stable-mask py3.7" (diff)
downloadgentoo-fce43338666f8d654bfa891b3e63ba57bbc3e312.tar.gz
gentoo-fce43338666f8d654bfa891b3e63ba57bbc3e312.tar.bz2
gentoo-fce43338666f8d654bfa891b3e63ba57bbc3e312.zip
dev-python/testpath-0.4.4: version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/testpath/Manifest1
-rw-r--r--dev-python/testpath/testpath-0.4.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
index 631cb2c9ded1..cc82c12571b9 100644
--- a/dev-python/testpath/Manifest
+++ b/dev-python/testpath/Manifest
@@ -1 +1,2 @@
DIST testpath-0.3.1.tar.gz 91333 BLAKE2B 86787b9677e8baa6d45fb5e6f047f2ab448e385201f20af3a3a9f33d6edd6c67e4eec09c178e815626096ad77d417ef99ddee562bf0fd7947b3f7ae1862f8156 SHA512 ab826cfb76d9a3ed6f1b178240f6bf61439bd792be26b5ad407b5c3efaa455b48965ceaf17e4ca6a4bc706465a8ed1c6c31a1572df5beeea2bb8db7814dc04f0
+DIST testpath-0.4.4.tar.gz 92101 BLAKE2B e607fbccf66570ebe29779701bac11048751e9ee8381cd7841ba5dc55e02ee2edc32e8fd8a4a869fdd786f0c4bacdb5e7efc644e0111c24a786631257a08c9cb SHA512 4435c99325d535c713e88b59ce16704e10947232e4eccfe0e792ff9288b65e677417881ce8bbb69577aebb4b9ef793621d8e54898ecb158d07fc22e8445950e2
diff --git a/dev-python/testpath/testpath-0.4.4.ebuild b/dev-python/testpath/testpath-0.4.4.ebuild
new file mode 100644
index 000000000000..17edd643cdd0
--- /dev/null
+++ b/dev-python/testpath/testpath-0.4.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2-setup.py.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}