summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 14:33:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 14:33:34 +0100
commitfce9b24bb396d4a64706227e06ec1eaa43c1a5de (patch)
tree6c41f9f7536e5c896769cf22ec9b236ae778597c
parentxfce-base/exo: Bump to 4.17.4 (diff)
downloadgentoo-fce9b24bb396d4a64706227e06ec1eaa43c1a5de.tar.gz
gentoo-fce9b24bb396d4a64706227e06ec1eaa43c1a5de.tar.bz2
gentoo-fce9b24bb396d4a64706227e06ec1eaa43c1a5de.zip
xfce-base/xfdesktop: Bump to 4.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.17.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index f25b74ab28b7..8c6ee6acb211 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -2,3 +2,4 @@ DIST xfdesktop-4.16.0.tar.bz2 2041114 BLAKE2B 153a11b27b3ac92ded0c97257f19b4bc90
DIST xfdesktop-4.16.1.tar.bz2 1942859 BLAKE2B fa4dad67396e794426d619aa71c490a6a92cdd19c26519831062803c15185238115b731490b848626a82e1f800059acd9f49893ae79dbeb479d665acb9007209 SHA512 87e90c2946c80befc38bf724fff6a834d462c47439b727d172e766765d4e7e200a2415c271459b2e820b6d8425f7e92c928ba9a098e63473acf0e7369c122cfb
DIST xfdesktop-4.17.0.tar.bz2 1968275 BLAKE2B 37b2c752bce64a0ab23198ad11d02375136e8733ff0d0de35c21f7ad9bf290067afcd5e0d1438e5db1cec88911ac3bedfce753c279ec7e1a9f02d18d08b1435d SHA512 2926ee7cc7a8e3016daea851cfaa525977cbacd8d16f475ece097104c4fa105e3c32ecdd97db99d9c1844b8a2219e86cb8776b377585cf6b037846a0ff683c19
DIST xfdesktop-4.17.1.tar.bz2 1951042 BLAKE2B 13cc2da9352d03c9f492c244927f7971f561e04544b9997509b78ea17b7229a886b06620ef959ae83b984366c43256e690ea81f9a5680c6c515404a86f296c4d SHA512 c1384059dd1214b87baf375e0b1ae8f9facc039e46adc5923d0288e0ed48583bb5d30775f9e47b685bc7d671e0319d2a383cace89ff913fe5a963a57df6406a5
+DIST xfdesktop-4.17.2.tar.bz2 1981765 BLAKE2B b0a5d84daf3999d4ac0b700e3752d3a7e468ea4ee241c3b19ade081c01cecb4b38499abeb9e2d66ab6abb78d6ae1f43c6fca393034b1283bd19ef9fd4a366604 SHA512 13e35fb6694fd1a5566d6bbcea0cf587a48843f1a5b5c8bfcad0ed2cec856967be24dbb4655f0aa48535338803c9af984f23c1139bb3cbb6955d4295b31e0f63
diff --git a/xfce-base/xfdesktop/xfdesktop-4.17.2.ebuild b/xfce-base/xfdesktop/xfdesktop-4.17.2.ebuild
new file mode 100644
index 000000000000..4676aeb9817c
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.17.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfdesktop/start
+ https://gitlab.xfce.org/xfce/xfdesktop/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+DEPEND="
+ >=x11-libs/cairo-1.12
+ >=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.14:3
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-4.17.10:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}