summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-17 08:48:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-17 09:28:42 +0200
commitfcedcbbe8d14b7d3863e55992c1f9541bbb78db7 (patch)
treea8f2b5df3a866e296d6708e26e6b664a7563e364
parentmedia-video/smplayer: Added missing dependency on dev-qt/qtdbus:5 (diff)
downloadgentoo-fcedcbbe8d14b7d3863e55992c1f9541bbb78db7.tar.gz
gentoo-fcedcbbe8d14b7d3863e55992c1f9541bbb78db7.tar.bz2
gentoo-fcedcbbe8d14b7d3863e55992c1f9541bbb78db7.zip
dev-python/google-api-core: Bump to 1.31.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-1.31.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index c8d0097e9492..059a042d82f6 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,2 +1,3 @@
DIST google-api-core-1.30.0.tar.gz 134595 BLAKE2B 104f52bafb68fd91904c02cbd6d3dd2e32c160a528f58e9af3612fc4f7a9934c522f79895b50982b46ee77947af7eb52557bf304b6f2624b97b5082905511829 SHA512 cc14f9c67bac99290665e2b85a97eacf43cdd2a0e4668ecbc7dd8e7131a7e4e908aca2be6d65797d0838081a02768354703762a1a80fa0b666efb81448b27899
DIST google-api-core-1.31.1.tar.gz 134947 BLAKE2B 112e705f8a2d945a207c10096a3cd8c1c65bf806339e8d688cc5638d234c1de03d168099414dd7314b8d3129d6d0e198208cddf15369b84ad837b9da90e8499c SHA512 29c84b98ae39416dbcb8ba7412237007bddea6e9a3af07c1f7753bfe57576125325a6412b73ab7d58c57257405b4b6aa36e043d0cf2496517828c7594f6698ef
+DIST google-api-core-1.31.2.tar.gz 135491 BLAKE2B d2567f628ac888b8f708b5e62c7a34cdad592e98689b3208041e48f08345da5df7da295d261af73c8e89041c91297a90af243b24c250095493af07c6d892459f SHA512 e819bbaadf1aedf78cb397c9a5a9677fbc625285a4f3d14620e5af0ec125f97eaabe18e34a669daee3bd51520de0818a4e2f451f83502ad78adf77e4c739fa67
diff --git a/dev-python/google-api-core/google-api-core-1.31.2.ebuild b/dev-python/google-api-core/google-api-core-1.31.2.ebuild
new file mode 100644
index 000000000000..08e9f19f949f
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-1.31.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+ https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO: package proto-plus
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore_with_nesting
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}