summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-12 13:52:35 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-12 13:52:35 +0200
commitfcfdec3f53987fcf7c76af501ef2d8f9b0210695 (patch)
tree22c8b942c8b6511092e7d7006f970037e9ea535f
parentdev-perl/Text-BibTeX: Remove old (diff)
downloadgentoo-fcfdec3f.tar.gz
gentoo-fcfdec3f.tar.bz2
gentoo-fcfdec3f.zip
dev-perl/Text-BibTeX: Version bump to 0.88
Closes: https://bugs.gentoo.org/682662 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--dev-perl/Text-BibTeX/Manifest1
-rw-r--r--dev-perl/Text-BibTeX/Text-BibTeX-0.880.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Text-BibTeX/Manifest b/dev-perl/Text-BibTeX/Manifest
index d6f15ec689d9..1d3d6bcb902a 100644
--- a/dev-perl/Text-BibTeX/Manifest
+++ b/dev-perl/Text-BibTeX/Manifest
@@ -1 +1,2 @@
DIST Text-BibTeX-0.85.tar.gz 299430 BLAKE2B bec61d93a4a0814bf1a6f357481da5ba337dd2ec4699ead948c9d4a48062664e77781babb82279582d04e3aee2ba26eab6c6a5b31af3008a076612c6f8cc4261 SHA512 e9ed337bde11b26626fc43c03bead2be54c0724194e19b4f543923634533220bbd68588f6349892eba0e6df6d305a51350fe82cfcb6cd24ea154284e4819b841
+DIST Text-BibTeX-0.88.tar.gz 301812 BLAKE2B 8a8249a95ef6a8af29346ba647543ebfb7cc24f18271fb79f2bb5b427b6e1fdc38c4e485ee7fba33b22f061c075533871fe6f6e226f6825313618d70632726c8 SHA512 63425590feb479b43b70605144edad400650471ddefbc3dc40f5bd1b6c78e5e50eabaf60501e469de520e36221bebd1806eae8d45124b59feef9446fc3257d18
diff --git a/dev-perl/Text-BibTeX/Text-BibTeX-0.880.0.ebuild b/dev-perl/Text-BibTeX/Text-BibTeX-0.880.0.ebuild
new file mode 100644
index 000000000000..b852e9072e22
--- /dev/null
+++ b/dev-perl/Text-BibTeX/Text-BibTeX-0.880.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=AMBS
+DIST_VERSION=0.88
+DIST_EXAMPLES=( "examples/*" "scripts/*" )
+
+inherit perl-module
+
+DESCRIPTION="A Perl library for reading, parsing, and processing BibTeX files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ !dev-libs/btparse
+ virtual/perl-Encode
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Unicode-Normalize
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Config-AutoConf-0.160.0
+ >=dev-perl/ExtUtils-LibBuilder-0.20.0
+ >=virtual/perl-ExtUtils-CBuilder-0.270.0
+ >=dev-perl/Module-Build-0.360.300
+ test? (
+ >=dev-perl/Capture-Tiny-0.60.0
+ )
+"
+src_prepare() {
+ sed -i -e "/#include <stdio.h>/a #include <string.h>"\
+ btparse/tests/{tex,purify,postprocess,name,macro}_test.c || die
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+ doheader btparse/src/btparse.h
+ doheader btparse/src/bt_config.h
+}