summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-03 17:32:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-04 06:40:48 +0100
commitfd13ad2739c8f56223857ad0a19f10ab6e4d00ec (patch)
treedbf63112d67b704c52b015648fe1aba0fb4892fc
parentvirtual/dist-kernel: Bump to 5.15.77 (diff)
downloadgentoo-fd13ad27.tar.gz
gentoo-fd13ad27.tar.bz2
gentoo-fd13ad27.zip
sys-kernel/vanilla-kernel: Bump to 6.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-6.0.7.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index d3add21c5121..1f9c91356592 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -46,3 +46,5 @@ DIST linux-6.0.5.tar.sign 987 BLAKE2B d8c7ceab01ab36ade7322ff141fab940fc95b4126d
DIST linux-6.0.5.tar.xz 133898040 BLAKE2B 71afe2e227bbab9b40ccbd3dda4aacbe1ba7f45b85c863c57a759a91d18d215cdc16c8bfd28e2d2bcd2a510c49b7fc84531d21695ad81895172ca6997ffe0f5a SHA512 90c0610be2bbca8841ff757b09d71c5d1efdcbc3cf0840d3f1d7a1b9a4854aa1eca36cfec0926dc191d35c5cbf71fea214097d831af2a34036c9a598f0ac55ad
DIST linux-6.0.6.tar.sign 987 BLAKE2B 5501a11c6d3d9edac1b96a6fc17df93de7469473d1bb041c8a15e52aed2e3b748b596fe05d60efc4e594ec84d0feb10882f4f8f169707bdee16dda517174a8a9 SHA512 cc76cbcdf8e62393b207bb62bdc760b27486e2ed3b2178f1d1b5e8868aa62a0bd9a99211e28c51515f713ac161d5fe4c5eafcc762e835278f2bd29928faf323f
DIST linux-6.0.6.tar.xz 133904196 BLAKE2B af53568340db3d63e3bbe8c5f27fff1e285b332845b9af960ee230c116e0555cc50857b6617d1b54f56e8de6717a940ff443cae9bf7dd8cc81326fe15ec6da5f SHA512 4589558159bf75d5df7b91517523d5f1415315e95da36df6fc9060aff71d235c4a63f9189d5a04a0ca91cf1dd94dac1d137c6f722b79bcdabba87aac9aa7a221
+DIST linux-6.0.7.tar.sign 987 BLAKE2B c5c8d081bab21ea3639f10621ec3a998eb955edaa370db3c24c77b9c2f616ef850b520f33d9cef764d7c635f859c9ae81be0f5eaa98922dc9bcb46542cc6a1fd SHA512 a4c25f637929e4209dd51513537391e22d7e09fe0bdc885309659856f5f9428b3e432838e1a3c3e875cd012560b8796dca2f9ccb40f2f305c727e599890f832e
+DIST linux-6.0.7.tar.xz 133884956 BLAKE2B 3d40325979982cf55c507646a34405287a87de8272a7cbd43906f7f06ec75621642cba3a42cb3192d395422db9e2a4079adaa191589646d9d72157a3a410cdfe SHA512 a03e67781a3b5593e1f663907079fe4618c0259634d5f8dfed620884c2c154f45e4d371b70353f8dbc88f71148b8a31c8863b26756e81bf82699a2b72be9df8e
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-6.0.7.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-6.0.7.ebuild
new file mode 100644
index 000000000000..a77bd2fb0699
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-6.0.7.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit kernel-build toolchain-funcs verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+# forked to https://github.com/projg2/fedora-kernel-config-for-gentoo
+CONFIG_VER=6.0.3-gentoo
+GENTOO_CONFIG_VER=g3
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+BDEPEND="
+ debug? ( dev-util/pahole )
+ verify-sig? ( sec-keys/openpgp-keys-kernel )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ hppa)
+ return
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}