summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 14:12:52 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:12 -0500
commitfd15bb33434ad97efc21018a00efda6d97d3c30d (patch)
tree96465f0082b31686b77316105e64fb592cbea981
parentdev-gap/polymaking: new package, add 0.8.7 (diff)
downloadgentoo-fd15bb33434ad97efc21018a00efda6d97d3c30d.tar.gz
gentoo-fd15bb33434ad97efc21018a00efda6d97d3c30d.tar.bz2
gentoo-fd15bb33434ad97efc21018a00efda6d97d3c30d.zip
dev-gap/qpa: new package, add 1.34
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-gap/qpa/Manifest1
-rw-r--r--dev-gap/qpa/metadata.xml30
-rw-r--r--dev-gap/qpa/qpa-1.34.ebuild23
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-gap/qpa/Manifest b/dev-gap/qpa/Manifest
new file mode 100644
index 000000000000..7d94eace86de
--- /dev/null
+++ b/dev-gap/qpa/Manifest
@@ -0,0 +1 @@
+DIST qpa-1.34.tar.gz 379124 BLAKE2B b272f7ee0eafb8bddaef90ecf5d05e5e54c08c3757357cce5006a58ecaf9304361bea453671c61120a0a04ed5b2715eabcbe1cfd428ffea707ece3287b6aab1c SHA512 456f6c6668cbc385ffe8dedd545bcda27c1b02197c8952236215e46139b88cdbe4da85b7023410a3ba2c0acb641b79e16a136ec790c7c3ca852c555b2f8b308e
diff --git a/dev-gap/qpa/metadata.xml b/dev-gap/qpa/metadata.xml
new file mode 100644
index 000000000000..d3d268d107e3
--- /dev/null
+++ b/dev-gap/qpa/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The QPA package provides data structures and algorithms for doing
+ computations with finite dimensional quotients of path algebras, and
+ finitely generated modules over such algebras. The current version
+ of the QPA package has data structures for quivers, quotients of
+ path algebras, and modules, homomorphisms and complexes of modules
+ over quotients of path algebras.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/qpa</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/qpa/qpa-1.34.ebuild b/dev-gap/qpa/qpa-1.34.ebuild
new file mode 100644
index 000000000000..ddd175960b24
--- /dev/null
+++ b/dev-gap/qpa/qpa-1.34.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Quivers and Path Algebras in GAP"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="dev-gap/gbnp"
+
+gap-pkg_enable_tests
+
+src_install() {
+ gap-pkg_src_install
+ use examples && dodoc -r examples
+}