summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-04 20:51:39 +0100
committerBen Kohler <bkohler@gentoo.org>2021-02-09 10:59:22 -0600
commitfd2a72e2b447db3b0a3554f7b3918e7f63a9bedc (patch)
treefe078b1a4308c0cdfd236c2866ac1a4b4ecee3c7
parentapp-pda/jpilot: Port to EAPI 7 (diff)
downloadgentoo-fd2a72e2.tar.gz
gentoo-fd2a72e2.tar.bz2
gentoo-fd2a72e2.zip
games-fps/quake2-icculus: Fix build with gcc-10
Closes: https://bugs.gentoo.org/733962 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--games-fps/quake2-icculus/files/quake2-icculus-0.16.1-fno-common.patch10
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild3
2 files changed, 12 insertions, 1 deletions
diff --git a/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-fno-common.patch b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-fno-common.patch
new file mode 100644
index 000000000000..8392ec63b784
--- /dev/null
+++ b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-fno-common.patch
@@ -0,0 +1,10 @@
+--- a/src/client/client.h
++++ b/src/client/client.h
+@@ -49,7 +49,6 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #ifdef QMAX
+ #define random() ((rand () & 0x7fff) / ((float)0x7fff))
+ #define crandom() (2.0 * (random() - 0.5))
+-vec3_t clientOrg; //lerped org of client for server->client side effects
+
+ void vectoangles2 (vec3_t value1, vec3_t angles);
+
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
index 13756e436dc6..5a5e6b994311 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
@@ -70,7 +70,8 @@ src_prepare() {
"${FILESDIR}"/${P}-x11_soft.patch \
"${FILESDIR}"/${P}-x11_mouse.patch \
"${FILESDIR}"/${P}-alsa.patch \
- "${FILESDIR}"/${P}-ia64.patch
+ "${FILESDIR}"/${P}-ia64.patch \
+ "${FILESDIR}"/${P}-fno-common.patch
if use xatrix ; then
epatch "${FILESDIR}/${P}"-gcc41.patch