summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-07 10:56:39 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-07 10:56:39 -0700
commitfd2e1e8be1bd85bf2e731656a83994b2c139962e (patch)
tree05688e0bf883641abcea8772a488bcdacf2afa4d
parentdev-python/pyu2f-0.1.4-r1: revbump, EAPI=7, py38 (diff)
downloadgentoo-fd2e1e8b.tar.gz
gentoo-fd2e1e8b.tar.bz2
gentoo-fd2e1e8b.zip
dev-python/google-reauth-python-0.1.0-r1: revbump, EAPI=7, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild b/dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..d9c8d75a6df2
--- /dev/null
+++ b/dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based U2F host library"
+HOMEPAGE="https://github.com/google/google-reauth-python"
+SRC_URI="https://github.com/google/google-reauth-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.rst CONTRIBUTING.rst README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:'some_origin'.encode('ascii'):'some_origin':" \
+ -e "s:SignResponse('key_handle', 'resp',:SignResponse('key_handle'.encode(), 'resp'.encode(),:" \
+ -i tests/test_reauth.py || die
+
+ distutils-r1_python_prepare_all
+}