summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-25 03:25:34 +0000
committerSam James <sam@gentoo.org>2022-11-25 03:25:42 +0000
commitfd4b7ae5796c5730482d4f2e632709f14632e1d3 (patch)
tree650647762df2794e39f1c36836ae11f4c5304080
parentnet-voip/telepathy-salut: Drop gnome@ as a maintainer (diff)
downloadgentoo-fd4b7ae5796c5730482d4f2e632709f14632e1d3.tar.gz
gentoo-fd4b7ae5796c5730482d4f2e632709f14632e1d3.tar.bz2
gentoo-fd4b7ae5796c5730482d4f2e632709f14632e1d3.zip
dev-db/sqlite: fix tests w/ ICU 72
Closes: https://bugs.gentoo.org/882605 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/sqlite/files/sqlite-3.39.4-icu-72-test.patch29
-rw-r--r--dev-db/sqlite/sqlite-3.39.4.ebuild6
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.39.4-icu-72-test.patch b/dev-db/sqlite/files/sqlite-3.39.4-icu-72-test.patch
new file mode 100644
index 000000000000..54de04d11f06
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.39.4-icu-72-test.patch
@@ -0,0 +1,29 @@
+https://sqlite.org/src/vpatch?from=18e89a436daa18a8&to=a2b6883ac2ef878f
+https://sqlite.org/forum/forumpost/072d2fddc4
+https://bugs.gentoo.org/882605
+--- a/test/fts3expr4.test
++++ b/test/fts3expr4.test
+@@ -48,11 +48,20 @@
+
+ # In "col:word", if "col" is not the name of a column, the entire thing
+ # is passed to the tokenizer.
+ #
+ do_icu_expr_test 1.7 {a:word} {PHRASE 0 0 word}
+-do_icu_expr_test 1.8 {d:word} {PHRASE 3 0 d:word}
++# do_icu_expr_test 1.8 {d:word} {PHRASE 3 0 d:word}
++do_test 1.8 {
++ set res [
++ db one {SELECT fts3_exprtest('icu en_US', 'd:word', 'a', 'b', 'c')}
++ ]
++ expr {
++ $res=="PHRASE 3 0 d:word" ||
++ $res=="AND {AND {PHRASE 3 0 d} {PHRASE 3 0 :}} {PHRASE 3 0 word}"
++ }
++} 1
+
+ set sqlite_fts3_enable_parentheses 0
+
+ do_icu_expr_test 2.1 {
+ f (e NEAR/2 a)
+
+
diff --git a/dev-db/sqlite/sqlite-3.39.4.ebuild b/dev-db/sqlite/sqlite-3.39.4.ebuild
index a2eb7c1e987f..ffcf6d08808b 100644
--- a/dev-db/sqlite/sqlite-3.39.4.ebuild
+++ b/dev-db/sqlite/sqlite-3.39.4.ebuild
@@ -53,6 +53,10 @@ else
S="${WORKDIR}/${PN}-src-${SRC_PV}"
fi
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.39.4-icu-72-test.patch
+)
+
_fossil_fetch() {
local distdir="${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}"
local repo_id="${1}"
@@ -139,7 +143,7 @@ src_unpack() {
}
src_prepare() {
- eapply_user
+ default
eautoreconf