summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 06:09:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 06:27:46 +0200
commitfd528f32558b029c9628aeafb4d31b9cc61584f6 (patch)
tree10dbca2789de158d2f468723d94c33f3dc2daf94
parentdev-python/slixmpp: Bump to 1.8.2 (diff)
downloadgentoo-fd528f32.tar.gz
gentoo-fd528f32.tar.bz2
gentoo-fd528f32.zip
dev-python/pylint: Bump to 2.13.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.13.5.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index e2615338cac4..a48829c2ade7 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -4,3 +4,4 @@ DIST pylint-2.13.1.gh.tar.gz 1116054 BLAKE2B 633636f97e284a8a93c598261b90019ea35
DIST pylint-2.13.2.gh.tar.gz 1116482 BLAKE2B da35c9f39781bbd796e2ec055b41c44211588d7da360fd27f81eef57a3f5c65e27931ca927b41692627c9914f5c28e3262c0f34a45c38b20aa1b83710ab1d1f1 SHA512 15274658cf3067ffa6635a94f2c75d8854b3843be45ea5dc5896bc12583b156428858baeed19eed4bfab35489326d70d0cce1375354d9ec97d00cfd895fc4a47
DIST pylint-2.13.3.gh.tar.gz 1116747 BLAKE2B 9ab6ff4746f78472de9c248754d102e55e8cb60d3ead8c5079cfe851b2b7c8e16afc9b0be02041cf24e789784200b90751ad0bcf172eb6d4edd88463863d18ac SHA512 0bda6d89219ad6f7f64f1361f95b85a34e3bc70f9f18f71eaa3d69deb47ab6fc056000c13a11c8c5644f0a9789eac2a5c262ddcf96302aeebfa16aa2e3b3086c
DIST pylint-2.13.4.gh.tar.gz 1117488 BLAKE2B a660c15c41b529d932a21d438c7cf0f3b97683d6b1452f4383193f97dd22ba6e216a7dc8c3677cb1cb0ab5b76ddb936afa2d87df38d41950e2249bd8867bf44d SHA512 2c0c60908f89bf7a2552f65e0b4957ee6223f5429a6c2ec997aaf75572b11e4247e159da744937dbc7752ebd5eab0a0c873d129983de09ea0954f35f47a1f524
+DIST pylint-2.13.5.gh.tar.gz 1118551 BLAKE2B 70ee4254aa140aba16adfe67aeb896d9c455843dfa945d335b5ba48e85c9d2d8f057223bc74bd4c0c0bfa2d343a9f78e783705b885caaee6895fcddf7ce23ccb SHA512 e399239fbea58260b17f226dddb63f1e6a2f12cdd601a4e73913a169d23fe2b6085e776bf8144e2c5a555dfdc1b28a5818a4103969d504b638b6b41ee296d182
diff --git a/dev-python/pylint/pylint-2.13.5.ebuild b/dev-python/pylint/pylint-2.13.5.ebuild
new file mode 100644
index 000000000000..168eae7e434b
--- /dev/null
+++ b/dev-python/pylint/pylint-2.13.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~riscv ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/setup.cfg#L43 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.12[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.11.0[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}