summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-02-08 13:38:31 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-02-08 13:38:56 +0700
commitfd5a2df7fb5ade9bb41b49f85bf2b4244a748a78 (patch)
tree5c44cb34e8ae2d838fd68ff0348f342450977578
parentmedia-gfx/ahoviewer: revbump, unrar is sub-slotted (diff)
downloadgentoo-fd5a2df7.tar.gz
gentoo-fd5a2df7.tar.bz2
gentoo-fd5a2df7.zip
dev-python/pygpgme: python3_9 added
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--dev-python/pygpgme/pygpgme-0.3-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pygpgme/pygpgme-0.3-r3.ebuild b/dev-python/pygpgme/pygpgme-0.3-r3.ebuild
new file mode 100644
index 000000000000..0f5f53075db2
--- /dev/null
+++ b/dev-python/pygpgme/pygpgme-0.3-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="A Python wrapper for the GPGME library"
+HOMEPAGE="https://launchpad.net/pygpgme https://pypi.org/project/pygpgme/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+python_configure_all() {
+ append-cflags $(gpgme-config --cflags)
+}