summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGavin Pryke <gavinlee303@gmail.com>2015-10-17 05:45:09 +0100
committerGavin Pryke <gavinlee303@gmail.com>2015-10-30 17:29:59 +0000
commitfd7de8dbb506c592f7d7039da3af5ce72449f9d1 (patch)
treeaff4e867bab4a6231558f993fc1838d2c5e86a30
parentmedia-libs/stops: fix HOMEPAGE, SRC_URI, EAPI=5. bug #437186 (diff)
downloadgentoo-fd7de8db.tar.gz
gentoo-fd7de8db.tar.bz2
gentoo-fd7de8db.zip
media-libs/zita-convolver: fix HOMEPAGE, SRC_URI, EAPI=5. bug #437186
The HOMEPAGE and SRC_URI for kokkinizita upstream was changed some time ago. These changes point said variables to the new location. Bumped to EAPI=5, revbumped and modified ebuild accordingly. Fix QA notice about missing soname symlink Re-add optimisations by cpu_flags_* that were patched out of the Makefile. Modifications as per github pull request #268 Bug: https://bugs.gentoo.org/show_bug.cgi?id=437186
-rw-r--r--media-libs/zita-convolver/files/zita-convolver-2.0.0-makefile.patch15
-rw-r--r--media-libs/zita-convolver/zita-convolver-2.0.0-r1.ebuild37
2 files changed, 45 insertions, 7 deletions
diff --git a/media-libs/zita-convolver/files/zita-convolver-2.0.0-makefile.patch b/media-libs/zita-convolver/files/zita-convolver-2.0.0-makefile.patch
index cfc45f4e4261..46c44173e8ac 100644
--- a/media-libs/zita-convolver/files/zita-convolver-2.0.0-makefile.patch
+++ b/media-libs/zita-convolver/files/zita-convolver-2.0.0-makefile.patch
@@ -1,8 +1,6 @@
-Index: zita-convolver-2.0.0/libs/Makefile
-===================================================================
---- zita-convolver-2.0.0.orig/libs/Makefile
-+++ zita-convolver-2.0.0/libs/Makefile
-@@ -28,9 +28,7 @@ VERSION = $(MAJVERS).$(MINVERS)
+--- libs/Makefile.orig 2015-10-16 16:00:45.639918246 +0100
++++ libs/Makefile 2015-10-28 15:52:17.539967709 +0000
+@@ -28,9 +28,8 @@
DISTDIR = zita-convolver-$(VERSION)
@@ -10,10 +8,11 @@ Index: zita-convolver-2.0.0/libs/Makefile
-CPPFLAGS += -mmmx -msse -mfpmath=sse -ffast-math -funroll-loops -fpermissive
-CPPFLAGS += -march=i686
+CPPFLAGS += -Wall -I. -fPIC -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS
++CXXFLAGS += -ffast-math
#CPPFLAGS += -DVECTORIZE
LDLFAGS +=
-@@ -46,7 +44,7 @@ ZITA-CONVOLVER_H = zita-convolver.h
+@@ -46,7 +45,7 @@
$(ZITA-CONVOLVER_MIN): $(ZITA-CONVOLVER_O)
@@ -22,11 +21,13 @@ Index: zita-convolver-2.0.0/libs/Makefile
install: $(ZITA-CONVOLVER_MIN)
-@@ -54,7 +52,6 @@ install: $(ZITA-CONVOLVER_MIN)
+@@ -54,8 +53,8 @@
install -d $(PREFIX)/$(LIBDIR)
install -m 644 $(ZITA-CONVOLVER_H) $(PREFIX)/include
install -m 755 $(ZITA-CONVOLVER_MIN) $(PREFIX)/$(LIBDIR)
- ldconfig
ln -sf $(ZITA-CONVOLVER_MIN) $(PREFIX)/$(LIBDIR)/$(ZITA-CONVOLVER_SO)
++ ln -sf $(ZITA-CONVOLVER_MIN) $(PREFIX)/$(LIBDIR)/$(ZITA-CONVOLVER_MAJ)
+ clean:
diff --git a/media-libs/zita-convolver/zita-convolver-2.0.0-r1.ebuild b/media-libs/zita-convolver/zita-convolver-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..86eeeacb498d
--- /dev/null
+++ b/media-libs/zita-convolver/zita-convolver-2.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="C++ library implementing a real-time convolution matrix"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/index.html"
+SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse"
+
+RDEPEND="sci-libs/fftw:3.0="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/libs
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ # upstream defaults to this on x86 but patched out of the Makefile
+ # try to reenable optimisation for x86 and allow building on other arch's
+ use cpu_flags_x86_sse && append-flags "-msse" "-mfpmath=sse"
+
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" LIBDIR="$(get_libdir)" install
+ dodoc "${WORKDIR}/${P}/AUTHORS"
+}