summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2018-03-11 16:12:03 -0500
committerDoug Goldstein <cardoe@gentoo.org>2018-03-11 16:13:26 -0500
commitfda72cd36523f138e88451b062735f4ff736b9a6 (patch)
tree75fd1c9e662736f13bd8368f75e18ee0a9eadff9
parentdev-util/cmdtest-0.30: added ~mips, bug 530672 (diff)
downloadgentoo-fda72cd36523f138e88451b062735f4ff736b9a6.tar.gz
gentoo-fda72cd36523f138e88451b062735f4ff736b9a6.tar.bz2
gentoo-fda72cd36523f138e88451b062735f4ff736b9a6.zip
dev-util/rustfmt: bump to newer version
Bump to latest "stable" version. There's technically a 0.9.0 but this is considered a "nightly" only. This package is being brought into the distribution of the Rust compiler in the future but it is still not stable and is still in a preview. Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
-rw-r--r--dev-util/rustfmt/rustfmt-0.8.6.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/rustfmt/rustfmt-0.8.6.ebuild b/dev-util/rustfmt/rustfmt-0.8.6.ebuild
new file mode 100644
index 000000000000..edb0b3728582
--- /dev/null
+++ b/dev-util/rustfmt/rustfmt-0.8.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2017-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.1.5
+
+EAPI=6
+
+CRATES="
+aho-corasick-0.6.3
+bitflags-0.9.1
+diff-0.1.10
+dtoa-0.4.1
+env_logger-0.4.3
+extprim-1.2.2
+getopts-0.2.14
+itoa-0.3.1
+kernel32-sys-0.2.2
+libc-0.2.23
+log-0.3.8
+memchr-1.0.1
+num-traits-0.1.39
+quote-0.3.15
+rand-0.3.15
+regex-0.2.2
+regex-syntax-0.4.1
+rustc_version-0.2.1
+rustfmt-0.8.6
+semver-0.6.0
+semver-parser-0.7.0
+serde-1.0.8
+serde_derive-1.0.8
+serde_derive_internals-0.15.1
+serde_json-1.0.2
+strings-0.1.0
+syn-0.11.11
+synom-0.11.3
+syntex_errors-0.59.0
+syntex_pos-0.59.0
+syntex_syntax-0.59.0
+term-0.4.5
+thread-id-3.1.0
+thread_local-0.3.3
+toml-0.4.1
+unicode-segmentation-1.2.0
+unicode-xid-0.0.4
+unicode-xid-0.1.0
+unreachable-0.1.1
+utf8-ranges-1.0.0
+void-1.0.2
+winapi-0.2.8
+winapi-build-0.1.1
+"
+
+inherit cargo
+
+DESCRIPTION="Tool to find and fix Rust formatting issues"
+HOMEPAGE="https://github.com/rust-lang-nursery/rustfmt"
+SRC_URI="$(cargo_crate_uris ${CRATES})"
+RESTRICT="mirror"
+LICENSE="Apache-2.0/MIT" # Update to proper Gentoo format
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""