summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-03 16:20:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-03 16:37:34 +0100
commitfda9b62d2f545dddadd8129cc2e686d06b240060 (patch)
tree0e6fab8c6cee0a9661cb0d41f30a137479cfd4b1
parentxfce-extra/xfce4-cpugraph-plugin: Revert "Bump to 1.2.9" (diff)
downloadgentoo-fda9b62d2f545dddadd8129cc2e686d06b240060.tar.gz
gentoo-fda9b62d2f545dddadd8129cc2e686d06b240060.tar.bz2
gentoo-fda9b62d2f545dddadd8129cc2e686d06b240060.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 9aa2d5515f75..65f3863acc05 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1 +1,2 @@
+DIST xfce4-cpugraph-plugin-1.2.10.tar.bz2 440958 BLAKE2B a64ced65c93edf86329ab72fc538960ad529cc090c323eaff2d0eb1ce0edce56d7aff56d58e450666c04f975a61880cbcfc5cf627817f7aa2b835de02c6a2f46 SHA512 414c2a5da9576d2ed1f5478a07ff5c51c45eaa0a8432a31b6fb2408b81f5ab4485e3b10486af26cf33a18d23e2dc3afe21bf88630e4db91adcfa3e0f80468cf3
DIST xfce4-cpugraph-plugin-1.2.8.tar.bz2 465181 BLAKE2B 68e8ee6ee8e943480626716f493d70046b8eeafbc9597d233e887009111fa5e6401fa652b0830163d413bfa7f28d004a75985cc72601e2b8cac7048dfd773e8b SHA512 f0f4201d0572997e8c610a25fcb957ebe4dd224204421aeba4e8ca54da71bdd97fa147dd7af7097b9e09ce6e1317836622a0bcbfec9589858010942993e27940
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.10.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.10.ebuild
new file mode 100644
index 000000000000..894630719613
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-cpugraph-plugin
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.12.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}