summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-06 09:58:54 +0000
committerSam James <sam@gentoo.org>2024-02-06 09:59:57 +0000
commitfdab46d0af0e9a511262b87502c804875217d2e7 (patch)
treec506fedc4a6b036bd3d4e45334b92f65cd457143
parentsec-keys/openpgp-keys-squid: new package, add 20240206 (diff)
downloadgentoo-fdab46d0af0e9a511262b87502c804875217d2e7.tar.gz
gentoo-fdab46d0af0e9a511262b87502c804875217d2e7.tar.bz2
gentoo-fdab46d0af0e9a511262b87502c804875217d2e7.zip
net-proxy/squid: add verify-sig support
Was originally going to do this with squid-6.7 but that is kind of semi-released: it doesn't have a tag in the git repo and 6.7 has a tarball up and it's signed but I have no idea what key signed it. Unlike 6.6 where it's from the known keyring. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-proxy/squid/Manifest1
-rw-r--r--net-proxy/squid/squid-6.6.ebuild9
2 files changed, 8 insertions, 2 deletions
diff --git a/net-proxy/squid/Manifest b/net-proxy/squid/Manifest
index b18a8701764a..e67b2b0eac8f 100644
--- a/net-proxy/squid/Manifest
+++ b/net-proxy/squid/Manifest
@@ -1,2 +1,3 @@
DIST squid-6.5.tar.xz 2554492 BLAKE2B 91ed91f9b0f56f440a7f15a63bbc3e19537b60bc8b31b5bf7e16884367d0da060c5490e1721dbd7c5fce7f4a4e958fb3554d6bdc5b55f568598f907722b651de SHA512 d3a40f5f390f0042a8e981ca28755a90dd520230a06b4246ba7bec0c98025ce1cdc7426797a666f769addd60238e28e1f04d2c701ea2ef2d7329dbe87b830d70
DIST squid-6.6.tar.xz 2554824 BLAKE2B 7c3c96f5cd5f819f6f020fb3e63ee8d9bb26b7fb4ff4405d7963a643c6766344e6492505bc1b33f3040ad800b3d7a3ad6a4b067b031ac4d178ddcac04c6e74dc SHA512 4ab261ed85ad674288467500aca9d8a48e3918b55f777635c0ba7a2551f248d35536848a5fbf2c946490a818004727f2aed33144f0a3ebab0be36cc4cffb020c
+DIST squid-6.6.tar.xz.asc 1193 BLAKE2B c37a400c51c30de35c6fe52123389c134d05670a36b1ffae4d67e7d06981bbf94788343daf2fdeafb782d464a977ee31bc601e3b1b92b45cd40ba6a6725b9a16 SHA512 08550569759c403a1a9747d08ea7055751fbf251355691074f6d09baca76a0987c5dff36e1f01b64edd446d568c7244b14124f6f8a1b19ccfc30293eed83a297
diff --git a/net-proxy/squid/squid-6.6.ebuild b/net-proxy/squid/squid-6.6.ebuild
index 99d72292a7dd..0f87a54910f4 100644
--- a/net-proxy/squid/squid-6.6.ebuild
+++ b/net-proxy/squid/squid-6.6.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit autotools flag-o-matic linux-info pam systemd toolchain-funcs
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/squid.gpg
+inherit autotools flag-o-matic linux-info pam systemd toolchain-funcs verify-sig
DESCRIPTION="Full-featured web proxy cache"
HOMEPAGE="http://www.squid-cache.org/"
@@ -13,7 +14,10 @@ MY_PV_MAJOR=$(ver_cut 1)
#r=-20181117-r0022167
r=
if [[ -z ${r} ]]; then
- SRC_URI="http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}.tar.xz"
+ SRC_URI="
+ http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}.tar.xz
+ verify-sig? ( http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}.tar.xz.asc )
+ "
else
SRC_URI="http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}${r}.tar.bz2"
S="${S}${r}"
@@ -72,6 +76,7 @@ BDEPEND="
dev-lang/perl
ecap? ( virtual/pkgconfig )
test? ( dev-util/cppunit )
+ verify-sig? ( sec-keys/openpgp-keys-squid )
"
PATCHES=(