summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-29 23:35:16 +0300
committerSam James <sam@gentoo.org>2022-05-01 05:50:25 +0100
commitfdb70d5b0aa516f8bbbbd256e2c26ed313593745 (patch)
treee286495e73a5e9da2c87592f5c8dd6645bbcb9f5
parentdev-lua/luaexpat: Stabilize 1.4.1 ppc, #841875 (diff)
downloadgentoo-fdb70d5b.tar.gz
gentoo-fdb70d5b.tar.bz2
gentoo-fdb70d5b.zip
dev-python/berkeleydb: keyword 18.1.5 for ~ia64 (append needed flag too)
Big thanks to matoro for reporting this package working with -O1 compilation. This was tested on guppy.ia64.d.g.o and indeed it passes tests now. (sam: matoro has identified -foptimize-sibling-calls is the issue which is implied by -O2). Bug: https://bugs.gentoo.org/814179 Thanks-to: matoro <matoro@airmail.cc> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/berkeleydb/berkeleydb-18.1.5.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/berkeleydb/berkeleydb-18.1.5.ebuild b/dev-python/berkeleydb/berkeleydb-18.1.5.ebuild
index 9c8e6b6acd04..e9c4a1c6fce3 100644
--- a/dev-python/berkeleydb/berkeleydb-18.1.5.ebuild
+++ b/dev-python/berkeleydb/berkeleydb-18.1.5.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
DISTUTILS_IN_SOURCE_BUILD=1
-inherit db-use distutils-r1
+inherit db-use flag-o-matic distutils-r1
# Tests aren't included in PyPi tarballs, so just manually clone from upstream
# at https://hg.jcea.es/pybsddb/ and prepare out tarball
@@ -17,7 +17,7 @@ SRC_URI="https://dev.gentoo.org/~arthurzam/distfiles/dev-python/${PN}/${P}.tar.x
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~riscv sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
RDEPEND="
|| (
@@ -55,6 +55,11 @@ python_configure_all() {
export BERKELEYDB_INCDIR="$(db_includedir ${DB_VER})"
export BERKELEYDB_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
export YES_I_HAVE_THE_RIGHT_TO_USE_THIS_BERKELEY_DB_VERSION=1
+
+ if use ia64; then
+ # bug #814179
+ append-flags -fno-optimize-sibling-calls
+ fi
}
python_test() {