summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-04-27 17:08:19 +0800
committerYixun Lan <dlan@gentoo.org>2022-04-27 17:08:19 +0800
commitfdb78703b7a110111da8e9a0030e98fa7659c607 (patch)
tree03b944656dd2ab10ca995faf296de355226f4d1d
parentdev-util/crash: add 8.0.1 (diff)
downloadgentoo-fdb78703.tar.gz
gentoo-fdb78703.tar.bz2
gentoo-fdb78703.zip
dev-util/crash: drop 8.0.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-util/crash/crash-8.0.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-util/crash/crash-8.0.0.ebuild b/dev-util/crash/crash-8.0.0.ebuild
deleted file mode 100644
index e37d6d2d621a..000000000000
--- a/dev-util/crash/crash-8.0.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-GDB_VERSION=10.2
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/crash-utility/crash.git"
- SRC_URI="mirror://gnu/gdb/gdb-${GDB_VERSION}.tar.gz"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/crash-utility/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- mirror://gnu/gdb/gdb-${GDB_VERSION}.tar.gz"
- KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
-fi
-
-DESCRIPTION="Red Hat crash utility; used for analyzing kernel core dumps"
-HOMEPAGE="https://crash-utility.github.io/"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-# there is no "make test" target, but there is a test.c so the automatic
-# make rules catch it and tests fail
-RESTRICT="test"
-
-src_prepare() {
- sed -i -e "s|ar -rs|\${AR} -rs|g" Makefile || die
- ln -s "${DISTDIR}"/gdb-10.2.tar.gz . || die
- default
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}