summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-16 22:35:54 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-16 22:39:08 +0200
commitfdbe3e4f916c311f2639946101716b35e18fd697 (patch)
tree6cfb24f87db52a38e31527d9f48b29a8afe6d453
parentgames-server/bedrock-server: drop old version (diff)
downloadgentoo-fdbe3e4f916c311f2639946101716b35e18fd697.tar.gz
gentoo-fdbe3e4f916c311f2639946101716b35e18fd697.tar.bz2
gentoo-fdbe3e4f916c311f2639946101716b35e18fd697.zip
app-misc/spacenavd: Fix USE=-X and deps for 0.7.1
Closes: https://bugs.gentoo.org/717690 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.7.1-no-x11.patch36
-rw-r--r--app-misc/spacenavd/spacenavd-0.7.1.ebuild11
2 files changed, 46 insertions, 1 deletions
diff --git a/app-misc/spacenavd/files/spacenavd-0.7.1-no-x11.patch b/app-misc/spacenavd/files/spacenavd-0.7.1-no-x11.patch
new file mode 100644
index 000000000000..71b9e26cd038
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.7.1-no-x11.patch
@@ -0,0 +1,36 @@
+From 0e7ee937e01b764a6bde28875a3bf0169dbfafa6 Mon Sep 17 00:00:00 2001
+From: John Tsiombikas <nuclear@member.fsf.org>
+Date: Sat, 8 Feb 2020 05:23:02 +0200
+Subject: [PATCH] dev.c should conditionally include proto_x11.h, only if
+ USE_X11 is defined. Closes github bug #22.
+
+---
+ src/dev.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/dev.c b/src/dev.c
+index 2074895..8a1b315 100644
+--- a/src/dev.c
++++ b/src/dev.c
+@@ -1,6 +1,6 @@
+ /*
+ spacenavd - a free software replacement driver for 6dof space-mice.
+-Copyright (C) 2007-2019 John Tsiombikas <nuclear@member.fsf.org>
++Copyright (C) 2007-2020 John Tsiombikas <nuclear@member.fsf.org>
+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -25,7 +25,10 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ #include "dev_serial.h"
+ #include "event.h" /* remove pending events upon device removal */
+ #include "spnavd.h"
++
++#ifdef USE_X11
+ #include "proto_x11.h"
++#endif
+
+ static struct device *add_device(void);
+ static struct device *dev_path_in_use(char const * dev_path);
+--
+2.26.1
+
diff --git a/app-misc/spacenavd/spacenavd-0.7.1.ebuild b/app-misc/spacenavd/spacenavd-0.7.1.ebuild
index e4ff48d27d98..c36104bb835d 100644
--- a/app-misc/spacenavd/spacenavd-0.7.1.ebuild
+++ b/app-misc/spacenavd/spacenavd-0.7.1.ebuild
@@ -14,9 +14,18 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="X"
-RDEPEND="X? ( x11-apps/xdpyinfo x11-libs/libXi )"
+RDEPEND="X? (
+ x11-apps/xdpyinfo
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXi
+ )"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-no-x11.patch # bug 717690
+)
+
pkg_setup() {
CONFIG_CHECK="~INPUT_EVDEV"
ERROR_CFG="Your kernel needs INPUT_EVDEV for the spacenavd to work properly"