summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 18:32:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 19:07:21 +0200
commitfdc874d1789a425a901a0ee0d3fe29170b51e51f (patch)
tree2dea0c6a0b6327a40e7fdccf97ccdef749a16b3c
parentmedia-video/kino: Drop 1.3.4-r1 (diff)
downloadgentoo-fdc874d1789a425a901a0ee0d3fe29170b51e51f.tar.gz
gentoo-fdc874d1789a425a901a0ee0d3fe29170b51e51f.tar.bz2
gentoo-fdc874d1789a425a901a0ee0d3fe29170b51e51f.zip
kde-frameworks/frameworkintegration: 5.85.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.85.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 58e98e65b739..021f09a6cee2 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.82.0.tar.xz 1755828 BLAKE2B 18c056daf8db8e06995d3f0b6985f9aabb05e8a4e7323635faf92701f04dbf135cf63221fe739504d2ccd7718dd02a6718ab7fa7ba84b86cb37394ff878b6e3f SHA512 5865e560789c50829c5648365db58497d0da141d1699f396ca431740e6f919ef68c89e2cb98ac1f320cdb07fae098de683b17c920f79a2b459ffd874935b6e77
DIST frameworkintegration-5.84.0.tar.xz 1755824 BLAKE2B 97782740521c7d6794a5f3063c4f2bea54f25d665857f7cabe8b67eb67d46ba26f8277d630cf1af71cc07c0342a36c25ae71fa1f7b0752f62aa2607291b6f7c7 SHA512 eb226600a1c17ebb9387eb42b212b6d2397f118ce2c52ba2463e8c8acf62b39f96aafe68573b9474bf4c0a13d6542bcadcb35ff4c8880425d448838630ea179f
+DIST frameworkintegration-5.85.0.tar.xz 1755792 BLAKE2B 0a9b6b9a35d20fac0d07cbcf23f4ca1e0627a0175a7298a6b6391b1f4e1c38a46e029dc21ff22ea397ad3de053485097137e5a0de818300000f0c0e4f03c474e SHA512 d496c3b2ff49a3e4ee43e3c208b7dd3df68561fed0fe519f22a163c3389683f7d776270fc6472f4b52677cf85eb4a73c6bb7bdeea951600f8f5302411677a4f3
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.85.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.85.0.ebuild
new file mode 100644
index 000000000000..8fbf5abdb53b
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.85.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}