summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-01 04:21:17 +0000
committerSam James <sam@gentoo.org>2022-12-01 04:21:17 +0000
commitfdd843377392e2b0d1a7542d10bc194604a77247 (patch)
treede3cf3c9f7c24281ac8844988fb376f3ff1c6939
parentnet-analyzer/argus: fix configure w/ clang 16 (diff)
downloadgentoo-fdd84337.tar.gz
gentoo-fdd84337.tar.bz2
gentoo-fdd84337.zip
net-analyzer/argus-clients: add 3.0.8.4
Closes: https://bugs.gentoo.org/808861 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/argus-clients/Manifest1
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.8.4.ebuild76
-rw-r--r--net-analyzer/argus-clients/files/argus-clients-3.0.8.3-configure-clang16.patch41
-rw-r--r--net-analyzer/argus-clients/files/argus-clients-3.0.8.4-autoconf-2.70.patch55
4 files changed, 173 insertions, 0 deletions
diff --git a/net-analyzer/argus-clients/Manifest b/net-analyzer/argus-clients/Manifest
index e93bb4e9c8d8..bec9030f51dc 100644
--- a/net-analyzer/argus-clients/Manifest
+++ b/net-analyzer/argus-clients/Manifest
@@ -1 +1,2 @@
DIST argus-clients-3.0.8.3.tar.gz 2753929 BLAKE2B 561b945ce5beb8d8d016579921417f405f421fd2afe2369ff0a4c5b8aaed44eca7591b43e64db00396cf963cc550753207c9b0e8d21d6b99d8c1ea0faaddb0e9 SHA512 ce6f6aaa21452f60c72498b5410cdc650eed6eec6d949daf7226e93f22d193db175e8051073cbfd258c127ed7cb445d6673ae38f386982dc19632ac55539960e
+DIST argus-clients-3.0.8.4.tar.gz 2773840 BLAKE2B 0b5a24bc6a5c3163a0ac19a3a354e6573491e130c4b854bc4c9b19e6dfa1d27acea8338a88e589043b839994182756b04e205d9ef6815b2f7dc347fb51405c88 SHA512 5b6a03528c31b534d56370b4b8189d223691bb0d8f465349e7850bf54b4663e9851bddb54060a8bc263be3b80f4eab829413a7ff4da312e6640e2f7191d65473
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.8.4.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.8.4.ebuild
new file mode 100644
index 000000000000..e3762e93f9bc
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.8.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="https://openargus.org/"
+SRC_URI="https://github.com/openargus/clients/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/clients-${PV}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ft geoip mysql sasl tcpd"
+
+RDEPEND="
+ net-analyzer/rrdtool[perl]
+ net-libs/libpcap
+ net-libs/libtirpc:=
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ sys-libs/zlib
+ ft? ( net-analyzer/flow-tools )
+ geoip? ( dev-libs/geoip )
+ mysql? ( dev-db/mysql-connector-c:0= )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch
+ "${FILESDIR}"/${PN}-3.0.7.21-curses-readline.patch
+ "${FILESDIR}"/${PN}-3.0.8.2-ar.patch
+ "${FILESDIR}"/${PN}-3.0.8.2-curses-readline.patch
+ "${FILESDIR}"/${PN}-3.0.8.2-my_bool.patch
+ "${FILESDIR}"/${PN}-3.0.8.3-configure-clang16.patch
+ "${FILESDIR}"/${PN}-3.0.8.4-autoconf-2.70.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR RANLIB
+
+ use debug && touch .debug
+ econf \
+ $(use_with ft libft) \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with sasl) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql mysql /usr)
+}
+
+src_compile() {
+ emake \
+ CCOPT="${CFLAGS} ${LDFLAGS}" \
+ RANLIB="$(tc-getRANLIB)" \
+ CURSESLIB="$( $(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin bin/ra*
+ dodoc ChangeLog CREDITS README CHANGES
+ doman man/man{1,5}/*
+}
diff --git a/net-analyzer/argus-clients/files/argus-clients-3.0.8.3-configure-clang16.patch b/net-analyzer/argus-clients/files/argus-clients-3.0.8.3-configure-clang16.patch
new file mode 100644
index 000000000000..ac974dbdf395
--- /dev/null
+++ b/net-analyzer/argus-clients/files/argus-clients-3.0.8.3-configure-clang16.patch
@@ -0,0 +1,41 @@
+https://github.com/openargus/clients/pull/7
+
+From 00264608bad9655d72927f31a2b2744b5e2e2e31 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 25 Nov 2022 19:03:24 +0100
+Subject: [PATCH] configure (AC_LBL_UNALIGNED_ACCESS): Avoid implicit function
+ decls
+
+Implicit function declarations were removed from the C language
+in 1999. Include the relevant header files to ensure that the
+check still works with future compilers. C99 also requires
+to declare the return types of all functions.
+--- a/acsite.m4
++++ b/acsite.m4
+@@ -298,8 +298,10 @@ AC_DEFUN([AC_LBL_UNALIGNED_ACCESS],
+ # include <sys/types.h>
+ # include <sys/wait.h>
+ # include <stdio.h>
++# include <stdlib.h>
++# include <unistd.h>
+ unsigned char a[[5]] = { 1, 2, 3, 4, 5 };
+- main() {
++ int main() {
+ unsigned int i;
+ pid_t pid;
+ int status;
+--- a/configure
++++ b/configure
+@@ -6711,8 +6711,10 @@ else
+ # include <sys/types.h>
+ # include <sys/wait.h>
+ # include <stdio.h>
++# include <stdlib.h>
++# include <unistd.h>
+ unsigned char a[5] = { 1, 2, 3, 4, 5 };
+- main() {
++ int main() {
+ unsigned int i;
+ pid_t pid;
+ int status;
+
diff --git a/net-analyzer/argus-clients/files/argus-clients-3.0.8.4-autoconf-2.70.patch b/net-analyzer/argus-clients/files/argus-clients-3.0.8.4-autoconf-2.70.patch
new file mode 100644
index 000000000000..b6a322fb6913
--- /dev/null
+++ b/net-analyzer/argus-clients/files/argus-clients-3.0.8.4-autoconf-2.70.patch
@@ -0,0 +1,55 @@
+https://sources.debian.org/patches/argus-clients/1:3.0.8.2-6.1/0007-Fix-autoconf-2.70-build.patch/
+https://bugs.gentoo.org/808861
+
+From: Boyuan Yang <byang@debian.org>
+Date: Fri, 1 Oct 2021 16:13:38 -0400
+Subject: Fix autoconf 2.70 build
+
+Bug-Debian: https://bugs.debian.org/978769
+--- a/acsite.m4
++++ b/acsite.m4
+@@ -715,13 +715,13 @@ AC_DEFUN([AC_QOSIENT_READLINE], [
+ esac
+ fi
+
+- AC_CHECK_HEADERS(readline/readline.h,
+- AC_CHECK_DECLS([rl_event_hook, rl_catch_signals, rl_done, rl_set_keyboard_input_timeout, rl_replace_line, rl_delete_text, rl_resize_terminal, rl_save_prompt ], [] , [] ,
+- [
++ AC_CHECK_HEADERS([readline/readline.h],
++ [AC_CHECK_DECLS([rl_event_hook, rl_catch_signals, rl_done, rl_set_keyboard_input_timeout, rl_replace_line, rl_delete_text, rl_resize_terminal, rl_save_prompt ], [] , [] ,
++ [[
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <readline/readline.h>
+- ]), ac_cv_found_readline=no)
++ ]])], [ac_cv_found_readline=no])
+
+ if test "$ac_cv_found_readline" != no; then
+ $1="-lreadline"
+--- a/configure.ac
++++ b/configure.ac
+@@ -41,17 +41,17 @@ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+ AC_PROG_YACC
+
+-AC_CHECK_PROGS(V_RANLIB, ranlib, @true)
+-AC_QOSIENT_LEX_AND_YACC(V_LEX, V_YACC, argus_)
++AC_CHECK_PROGS([V_RANLIB], [ranlib], [@true])
++AC_QOSIENT_LEX_AND_YACC([V_LEX], [V_YACC], [argus_])
+
+ # Checks for libraries.
+-AC_QOSIENT_READLINE(V_READLINE, V_INCLS)
++AC_QOSIENT_READLINE([V_READLINE], [V_INCLS])
+
+-CMU_SASL2(V_INCLS)
++CMU_SASL2([V_INCLS])
+ AC_CMU_MYSQL
+
+-AC_CHECK_HEADERS(zlib.h, [AC_CHECK_LIB(z, uncompress, ZLIB="-lz")])
+-AC_QOSIENT_FLOWTOOLS(V_FLOWTOOLS, V_INCLS)
++AC_CHECK_HEADERS([zlib.h], [AC_CHECK_LIB([z], [uncompress], [ZLIB="-lz"])])
++AC_QOSIENT_FLOWTOOLS([V_FLOWTOOLS], [V_INCLS])
+
+ if test ! -z "$V_FLOWTOOLS"; then
+ AC_DEFINE([ARGUS_FLOWTOOLS], [], [Using Flow Tools library])
+