summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-01 13:16:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-01 13:17:04 +0100
commitfde9912dc9e844e14c018d821e6a18989ceb440b (patch)
tree06464f51d9d76c3be23cf8769df45a39b3497099
parentxfce-base/xfce4-power-manager: Bump to 4.17.0 (diff)
downloadgentoo-fde9912d.tar.gz
gentoo-fde9912d.tar.bz2
gentoo-fde9912d.zip
xfce-base/thunar-volman: Bump to 4.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/thunar-volman/Manifest1
-rw-r--r--xfce-base/thunar-volman/thunar-volman-4.17.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/xfce-base/thunar-volman/Manifest b/xfce-base/thunar-volman/Manifest
index df5889df1fdc..bb9e338a04e8 100644
--- a/xfce-base/thunar-volman/Manifest
+++ b/xfce-base/thunar-volman/Manifest
@@ -1 +1,2 @@
DIST thunar-volman-4.16.0.tar.bz2 501194 BLAKE2B 3d2fce7bb9a52a950ab84fa9986387af01d7d55864bd8fc1a3051ab406c99648b4ba21d018e806baa07ec1ac7e2bc798eb402b1c0e115e52b58ccdbda0ca4c5f SHA512 33b7561e55491b793aa634dfa0b108788286e6b7a2f60a781b8ba10f73de74630520736ae99c4db66ae2da562a82bb1a6bdacd8307d6d452f26e647da6471af8
+DIST thunar-volman-4.17.0.tar.bz2 509829 BLAKE2B 1a287893b53d1ecc29346363861184d203b618d5668e2d508fd3aafc464514914699f3fc41195f55f6cca0f8888cfae66488add66f26d3de15a489fdddef25be SHA512 a5ef86efb9a3f0b5bf38b17e27be7ed8c60debb8dfa769f5f06df5b1bbce988b7ac1170c01a3215a4983c1a6352274c1bb6ecee1be2761b5471fa849e4c8a88f
diff --git a/xfce-base/thunar-volman/thunar-volman-4.17.0.ebuild b/xfce-base/thunar-volman/thunar-volman-4.17.0.ebuild
new file mode 100644
index 000000000000..d85d390c9a04
--- /dev/null
+++ b/xfce-base/thunar-volman/thunar-volman-4.17.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/thunar-volman
+ https://gitlab.xfce.org/xfce/thunar-volman/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+# CC for tvm-burn-cd.svg
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.50
+ dev-libs/libgudev:=
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/udev
+ >=xfce-base/thunar-1.6[udisks]
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}