summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-15 18:52:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-15 18:52:09 +0100
commitfdf9749d30f796d88ad801c2134f2de1782b2b1e (patch)
tree24c7b0282377ced7d98482a8eec4b20ff7dd4e78
parentdev-python/pytest-env: Remove old (diff)
downloadgentoo-fdf9749d30f796d88ad801c2134f2de1782b2b1e.tar.gz
gentoo-fdf9749d30f796d88ad801c2134f2de1782b2b1e.tar.bz2
gentoo-fdf9749d30f796d88ad801c2134f2de1782b2b1e.zip
dev-python/sentry-sdk: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.37.1.ebuild131
2 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index cc2460487116..cad27c3a8500 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,2 @@
-DIST sentry-python-1.37.1.gh.tar.gz 447142 BLAKE2B 16e495a69e4757520e4fa9854248f7fdd31056489b016d86a0f087b7a709fa70a1f9cf655c4e319e8a69cdedd138c34864d03907a7423be329dbd00f66a2c568 SHA512 193d20949ce87dc530bbc97a522fd0c8566ccd2d2f14287c8e903dd39bb8a19af7aa59de0bcb90f06375353c79cbc19af704a17844b2073860bc879d2b551542
DIST sentry-python-1.38.0.gh.tar.gz 448517 BLAKE2B de047d20e8dd90018a7ce8dd102efc7ce970bb269c04d643c67e9fb46a9ad9eebcd89b08dfe1f0782dc51f61478c6e472ed25262e8a2bca7cfb7e0d9936abe78 SHA512 dbdcb7f53ee8da6071befec7a619324c0baabb383bb000875992e82bca97d0f49c7a8836c91a2ae20ae814ed55bf485d01c4762a82761083a19b1db8557d6983
DIST sentry-python-1.39.1.gh.tar.gz 451286 BLAKE2B ff81f800f41d5f2c6a8ae0007338a394a176de4705753839e6bd4b74ac9aa21eb340582d6bc33e3a482c020fdc8307e472b9278ff101899f44a1a42429e158bd SHA512 0b162cc677b1e59434b6c58ccced4d84f6679b5ff733271938b07302e0e9a9d706304334282bd7b7e1c1f4026ed98fae3e5635cfac306e08a3aee801d75e1d7c
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.37.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.37.1.ebuild
deleted file mode 100644
index f7cba82b1d78..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-1.37.1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{11..12} )
-
-inherit distutils-r1
-
-MY_P=sentry-python-${PV}
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="
- https://sentry.io/
- https://github.com/getsentry/sentry-python/
- https://pypi.org/project/sentry-sdk/
-"
-SRC_URI="
- https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/python-socks[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-event[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # tests require Internet access
- tests/integrations/httpx/test_httpx.py
- tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/flask/test_flask.py
- tests/integrations/django/test_basic.py
- tests/integrations/socket/test_socket.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # broken by rq-1.10.1 (optional dep)
- tests/integrations/rq/test_rq.py
- # fastapi is not packaged
- tests/integrations/asgi/test_fastapi.py
- # TODO
- tests/integrations/bottle
- # TODO: causes breakage in other tests
- tests/integrations/starlette
- # TODO
- tests/integrations/tornado
- # requires mockupdb
- tests/integrations/pymongo
- # requires AWS access
- tests/integrations/aws_lambda
- )
-
- local EPYTEST_DESELECT=(
- # hangs
- 'tests/test_transport.py::test_transport_works'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/asgi/test_asgi.py::test_websocket
- tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
- tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_session_cookies_{filtered,removed}
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- # TODO
- tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
- tests/test_profiler.py::test_sample_buffer
- tests/test_profiler.py::test_thread_scheduler_takes_first_samples
- tests/test_profiler.py::test_thread_scheduler_takes_more_samples
- tests/test_profiler.py::test_thread_scheduler_single_background_thread
- # broken with py3.11, *shrug*
- tests/test_profiler.py::test_extract_stack_with_max_depth
- # TODO
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
- tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
- tests/test_scrubber.py::test_span_data_scrubbing
- # this is not even funny
- tests/test_utils.py::test_installed_modules
- # flaky hypothesis stuff
- tests/test_serializer.py::test_bytes_serialization_repr_many
- # TODO
- tests/integrations/aiohttp/test_aiohttp.py::test_basic
- tests/tracing/test_decorator_py3.py::test_trace_decorator_{,a}sync_py3
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p aiohttp -p pytest_forked
-}