summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-30 16:50:00 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-30 16:50:00 +0100
commitfe0690e870ea260798b7492dda60e2b0d804fa02 (patch)
tree559a1a04c3bceb73eea67ed443a833c308b40bd6
parentdev-python/swagger-spec-validator: drop old version (diff)
downloadgentoo-fe0690e870ea260798b7492dda60e2b0d804fa02.tar.gz
gentoo-fe0690e870ea260798b7492dda60e2b0d804fa02.tar.bz2
gentoo-fe0690e870ea260798b7492dda60e2b0d804fa02.zip
dev-python/drf-yasg: bump to version 1.20.0
Closes: https://bugs.gentoo.org/767025 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-python/drf-yasg/Manifest1
-rw-r--r--dev-python/drf-yasg/drf-yasg-1.20.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/drf-yasg/Manifest b/dev-python/drf-yasg/Manifest
index 40c1d18aa46a..15628630b387 100644
--- a/dev-python/drf-yasg/Manifest
+++ b/dev-python/drf-yasg/Manifest
@@ -1 +1,2 @@
DIST drf-yasg-1.17.1.tar.gz 1300642 BLAKE2B 6cb21bf901ee2612666bf076faecb2748f7af8ee30a8cd71f00d58bd26f837a8850725d1944d5f933c49ea65657870ff1ca351464db77303380cec85d8de3183 SHA512 b8e2e11fa3b18b3fd827e80674dfc6a99bda059455dfed9945a311dc43783a7871f5dcc92a2327174e6c28f3235c143ad73c8694cd2e24cd713f712662b3976d
+DIST drf-yasg-1.20.0.tar.gz 1800321 BLAKE2B 3db8b0b33c2919d4a331b06b1f6e324ce6e0e160c0454cb066e61cbf7bb580efadb5cd9624579492db3404edcc8e50753e63b6edae022842cd087b820779557d SHA512 b56cd00d7a09f197e95c0129e20e561ece783b4edb389b228027ab8768247ccba15db5768f52a3d5ac5a4c47faa7a447ed7eb9b22af2a21377a36dcb7e7b267f
diff --git a/dev-python/drf-yasg/drf-yasg-1.20.0.ebuild b/dev-python/drf-yasg/drf-yasg-1.20.0.ebuild
new file mode 100644
index 000000000000..d72f426f74b4
--- /dev/null
+++ b/dev-python/drf-yasg/drf-yasg-1.20.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Automated generation of Swagger/OpenAPI 2.0 schemas from Django Rest framework"
+HOMEPAGE="https://github.com/axnsan12/drf-yasg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+validation"
+
+RDEPEND="
+ >=dev-python/coreapi-2.3.3[${PYTHON_USEDEP}]
+ >=dev-python/coreschema-0.0.4[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15.34[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging
+ >=dev-python/djangorestframework-3.8[${PYTHON_USEDEP}]
+ >=dev-python/django-1.11.7[${PYTHON_USEDEP}]
+ validation? ( >=dev-python/swagger-spec-validator-2.1.0[${PYTHON_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"