summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 06:03:43 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:07:46 +0000
commitfe27a8ef786d37b1fbfe76fddc1c71d3eacb91ed (patch)
treeeec2fb69f9ee98545c07a882e2ec67f8a4811a5b
parentdev-python/pyxdg: mark ALLARCHES (diff)
downloadgentoo-fe27a8ef.tar.gz
gentoo-fe27a8ef.tar.bz2
gentoo-fe27a8ef.zip
dev-python/pyxattr: bump to 0.7.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pyxattr/Manifest1
-rw-r--r--dev-python/pyxattr/pyxattr-0.7.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
index 2e121df910ad..0e1aee75e057 100644
--- a/dev-python/pyxattr/Manifest
+++ b/dev-python/pyxattr/Manifest
@@ -1 +1,2 @@
DIST pyxattr-0.7.1.tar.gz 30580 BLAKE2B 748ce0610ebc1a074dee87dffc67a88e1def0ea467f13758d2d85f9f5c37954586d85dfb8ceb1b77f4ef637295d57a153849b00d773e2e79b06902974fe01663 SHA512 093cb3f9b9637194b9737c07da7dde45b3d5083ec16a9209af80d30c86da8f93badff5aada395415be3dd48da73004286e47d0aa0671c95e65b0492d02e86009
+DIST pyxattr-0.7.2.tar.gz 31550 BLAKE2B 3505300d7a50dc305068740379bb8edbefa29f228c797e2e74467a51f4b0a6b740203f89b8ed461218978214213a6cd778107f58eb07a64d6b45e25d0fb769ea SHA512 fb9b36d5d2fb9ab674daf40d6f5c7dbe50d847dcb6d9955d270ef3aed2d8e3540f8feebd934009f47d63f3c55882846a20f7ed733b0d0c004e7a1984e7106206
diff --git a/dev-python/pyxattr/pyxattr-0.7.2.ebuild b/dev-python/pyxattr/pyxattr-0.7.2.ebuild
new file mode 100644
index 000000000000..6202df6da8ee
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="https://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-apps/attr:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/recommonmark
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}